fatal: open database /etc/postfix/virtusertable.db: No such file or directory

Discussion in 'Installation/Configuration' started by Boppel, Feb 3, 2007.

  1. Boppel

    Boppel New Member

    I am running a openSuSE 10.2 64 bit server with the modified (openssl-devel added) perfect 10.2 32 bit installation.

    Everyting just runs terrific ;)

    The newest stable ISPconfig is also running great.

    But there is a small problem with Postfix. Sending und receiving mails works just fine - but after "playing" around with new accounts (users) in ISPconfig /var/log/mail brings an error:

    Code:
     fatal: open database /etc/postfix/virtusertable.db: No such file or directory
    
    And SMTP won't work anymore.

    After a
    Code:
    postmap /etc/postfix/virtusertable
    rcpostfix restart
    
    the problem seems to be solved but it will occure again and again.

    I guess this problem has something todo with

    Code:
    Feb  2 23:59:42 derivation postfix/smtpd[14437]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
    
    I mean postmap and restarting postfix will work for the short term but it is not a solution.

    Restarting ISPconfig server woks fine without any errors.

    In /home/admispconfig/ispconfig/ispconfig.log I can find the following warning whenever a user is edited.

    Code:
    03.02.2007 - 13:35:55 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
    

    Perhaps it has something todo with rights an the execution of postmap via PHP?!

    Thanks for your help!!

    Regards,

    Boppel
     
    Last edited: Feb 3, 2007
  2. till

    till Super Moderator

    ISPConfig executes the command as root user, so this sould be no problem.

    Do you get any error messages when you run the postmap command manually?
     
  3. Boppel

    Boppel New Member

    No - there are no errors. After running the postmap command and restarting postfix everything is fine. I was able to isolate the problem to one single web. Adding and editing users in all (as far as I can say now) other webs works without any errors. Counld the filesystem structure in this web be damaged?
     
  4. falko

    falko Super Moderator

    No, that's not the problem. I had the same problem once on a SuSE 10.2 system. On another installation (exactly the same setup) it was working (SuSE... sigh... :( ).

    Have you tried to reboot the system?
     
  5. Boppel

    Boppel New Member

    Not yet.


    BUT: It now seems to work - but who knows how long.

    Strange - I guess SuSE is going it's own way. I can try the same perfect installation with Ubuntu 06.06 server LTS, and check out if the same problem will occure (but I don't think so).
     
  6. falko

    falko Super Moderator

    They like to do that... :(
     

Share This Page