fastcgi port not listening for 2nd and 3rd site

Discussion in 'General' started by adrigen, Feb 25, 2013.

  1. adrigen

    adrigen New Member

    I have recently configured ispconfig3 with nginx on ubuntu 12.04.

    I notice that when I try to access a php page I am getting and error in the log of my 2nd site: "Primary script unknown".

    I notice that in the sites .conf file, fastcgipass is set to port 9011.
    In my first site, in which php works fine, the port is 9010.

    netstat -alnp | grep cgi
    unix 2 [ ACC ] STREAM LISTENING 9760 1659/fcgiwrap /var/run/fcgiwrap.socket

    There is nothing listening on 9011 though. Is ispconfig3 supposed to initiate this process?

    Thanks,
    Adrian
     
  2. almere

    almere HowtoForge Supporter

    Hey.

    What port do you have in setting "PHP-FPM start port" (System->Server config->Your server->Web->PHP Settings) ?
     
  3. adrigen

    adrigen New Member

    That is set to 9010.
    Why would the "sites" each be configured to different ports?

    (If I change things in the system config files would that cause problems with ispconfig?)

    Thanks
     
  4. falko

    falko Super Moderator

    Yes, but you can also use sockets. You can choose this on the Options tab of the website.
     

Share This Page