Fast-CGI php error question

Discussion in 'Installation/Configuration' started by bseibenick, Jan 6, 2010.

  1. bseibenick

    bseibenick New Member

    So far mod_php and suphp seem to work correctly on sites in my CentOS 5.4 ISPConfig install. However the fast cgi for php does makes apache not want to start. When I make the change in ISPConfig to enable fast cgi for php then after the vhost file is modified to a restart of apache I get an error:

    [root@dev1 httpd]# /etc/init.d/httpd restart
    Stopping httpd: [ OK ]
    Starting httpd: Syntax error on line 34 of /etc/httpd/conf/sites-enabled/
    Invalid command 'FCGIWrapper', perhaps misspelled or defined by a module not included in the server configuration

    The lines from the vhost file are:
    # suexec enabled
    SuexecUserGroup web1 client2
    # php as fast-cgi enabled
    <Directory /var/www/>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride all
    Order allow,deny
    Allow from all

    Do I need to manually install anything for the FCGIWrapper? Is there anything else I can check? I run Joomla CMS on most of my sites so I would like the option of suphp for the smaller ones and fast-cgi for the larger ones.

    Any thoughts would be appreciated.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed to install the fcgi php module as described in the ISPConfig 3 perfect setup guide for Centos 5.4:

    see page 5:

    yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-eaccelerator php-mbstring php-mcrypt php-mhash php-mssql php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel
  3. bseibenick

    bseibenick New Member

    It turns out what I really did was miss enabling the kbs-CentOS-Testing section of the repo file.


Share This Page