FAQ: Problem with FastCGI + SuEXEC: all sites running under www-data

Discussion in 'Tips/Tricks/Mods' started by Th0m, Feb 19, 2021.

Thread Status:
Not open for further replies.
  1. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    There have been several reports in the last week about a issue where the panel did not show up - some users already had the suspicion this happened after a PHP update from the SURY (Ondrej) repo.

    For example, this is one of the reports: https://www.howtoforge.com/community/threads/solved-cant-login-ispconfig-3-2-interface.86395/

    I have been searching for the issue and after doing a lot of testing, I opened a issue at the GitHub repo for issues with Ondrej's SURY repo.
    Turned out the problem was a update to the php-fpm config.

    EDIT: The official fix has been implemented and released. Run
    Code:
    sudo apt-get update && sudo apt-get upgrade
    to apply the fix instead of manually changing the config files.

    EDIT2: The issue surfaced in the Debian repo aswell now. The new packages where it has been resolved are not available yet. On Debian, follow these steps:
    You can resolve it for now by replacing
    Code:
    <If "-f %{REQUEST_FILENAME}">
    SetHandler "proxy:unix:/run/php/[email protected][email protected]|fcgi://localhost"
    </If>
    with
    Code:
    SetHandler "proxy:unix:/run/php/[email protected][email protected]|fcgi://localhost"
    (Replace @[email protected] with the correct version for the config file)

    in /etc/apache2/conf-available/php*-fpm.conf

    Code:
    nano /etc/apache2/conf-available/php*-fpm.conf
    This will open the config for every installed PHP version, and by changing the correct lines, all version will work correctly again.

    The cause of this problem will most likely be reverted in an upcoming update.


    You can find more information on this here: https://github.com/oerdnj/deb.sury.org/issues/1545

    If you disabled mpm_event as temporary workaround, re-enable it with
    Code:
    a2enmod http2
    a2enconf php7.4-fpm
    systemctl reload apache2
    a2dismod php7.4
    systemctl restart apache2
    a2dismod mpm_prefork
    a2enmod mpm_event
    systemctl restart apache2
     
    Last edited: Feb 20, 2021
    madmucho, SupuS, ArnisR and 6 others like this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thank's a lot @Th0m for tracking down the issue and contacting Ondrej to solve it!
     
    Shirokuma, Fire Fox and Th0m like this.
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    If you implemented the workaround earlier, you might be asked the following:
    Code:
    Configuration file '/etc/apache2/conf-available/php7.4-fpm.conf'
     ==> Modified (by you or by a script) since installation.
     ==> Package distributor has shipped an updated version.
       What would you like to do about it ?  Your options are:
        Y or I  : install the package maintainer's version
        N or O  : keep your currently-installed version
          D     : show the differences between the versions
          Z     : start a shell to examine the situation
     The default action is to keep your current version.
    *** php7.4-fpm.conf (Y/I/N/O/D/Z) [default=N] ? Y
    Make sure you answer "Y".
     
    ArnisR and Fire Fox like this.
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    One more note. The issue exists in the SURY repo for Debian aswell now. The workaround is the same.

    It is currently not clear when the updated packages with the fix for this issue will be released.
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    The updated packages are now available for Debian aswell. I have updated the post again.
     
Thread Status:
Not open for further replies.

Share This Page