Failure installing Roundcube with Debian Jessie

Discussion in 'ISPConfig 3 Priority Support' started by MaxT, Jun 26, 2017.

  1. MaxT

    MaxT Member HowtoForge Supporter

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The one you used is fine. Both are working, they just use different methods to install the software.

    Please check the file:

    /etc/apache2/conf-enabled/roundcube.conf

    and ensure that it contains this line:

    Alias /webmail /var/lib/roundcube

    and that the line is not commented out (no # in front of the line) and ensure that you restarted apache and that you access roundcube with http://www.yourdomain.tld/webmail
     
  3. MaxT

    MaxT Member HowtoForge Supporter

    yes, I have this inside /etc/apache2/conf-enabled/roundcube.conf although it doesn't work.
    Line is not commented.
    Code:
    # Those aliases do not work properly with several hosts on your apache server
    # Uncomment them to use it or adapt them to your configuration
    Alias /roundcube /var/lib/roundcube
    
    <Directory /var/lib/roundcube/>
      Options +FollowSymLinks
      # This is needed to parse /var/lib/roundcube/.htaccess. See its
      # content before setting AllowOverride to None.
      AllowOverride All
      <IfVersion >= 2.3>
        Require all granted
      </IfVersion>
      <IfVersion < 2.3>
        Order allow,deny
        Allow from all
      </IfVersion>
    </Directory>
    
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^favicon\.ico$ skins/larry/images/favicon.ico
    # security rules:
    # - deny access to files not containing a dot or starting with a dot
    # in all locations except installer directory
    RewriteRule ^(?!installer)(\.?[^\.]+)$ - [F]
    # - deny access to some locations
    RewriteRule ^/?(\.git|\.tx|SQL|bin|config|logs|temp|tests|program\/(include|lib|localization|steps)) - [F]
    # - deny access to some documentation files
    RewriteRule /?(README\.md|composer\.json-dist|composer\.json|package\.xml)$ - [F]
    </IfModule>
    
    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    </IfModule>
    
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault "access plus 1 month"
    </IfModule>
    
    FileETag MTime Size
    
    <IfModule mod_autoindex.c>
    Options -Indexes
    </ifModule>
    
    AllowOverride None
    Require all granted
    </Directory>
    
    <Directory /var/lib/roundcube/plugins/enigma/home>
    Options -FollowSymLinks
    AllowOverride None
    Require all denied
    </Directory>
    
    
    # Protecting basic directories:
    <Directory /var/lib/roundcube/config>
      Options -FollowSymLinks
      AllowOverride None
    </Directory>
    
    <Directory /var/lib/roundcube/temp>
      Options -FollowSymLinks
      AllowOverride None
      <IfVersion >= 2.3>
      Require all denied
      </IfVersion>
      <IfVersion < 2.3>
      Order allow,deny
      Deny from all
      </IfVersion>
    </Directory>
    
    <Directory /var/lib/roundcube/logs>
      Options -FollowSymLinks
      AllowOverride None
      <IfVersion >= 2.3>
      Require all denied
      </IfVersion>
      <IfVersion < 2.3>
      Order allow,deny
      Deny from all
      </IfVersion>
    </Directory>
    
    I have reviewed also the rest of files inside /etc/roundcube and I cannot find the problem.

    I note there is not any roundcube section (<Directory ...>) inside /etc/apache2/sites-available/ispconfig.conf. Is there need of someone?.

    Besides this, I cannot see any error line in the log files. :(
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You have an alias /roundcube but not an alias /webmail at the moment. You should be able to access roundcube in your website with /roundcube. If you want to access it with /webmail, then alter the alias in the way it is shown in the tutorial and restart apache.
     
  5. MaxT

    MaxT Member HowtoForge Supporter

    it doesn't work with Alias /webmail /var/lib/roundcube and then restarting apache. I don't know what happens.
    And no error messages inside /var/log/apache2/error.log

    Can I do a apt-get purge and reinstall of Roundcube including the delete of /etc/roundcube, /var/lib/roundcube and /usr/share/rouncube?
    In that case, Should I do any delete of some file or section inside /etc/apache2?. All it will be regenerated at the new install?

    thanks!
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    A reinstall of RoundCube should be no problem. Just ensure to delete the RoundCube MySQL user and database in case it still exists after you purged the package, e.g. with PHPMyAdmin. And just to be sure, you tried to reach RoundCube on port 80 and not 8080, right?
     
  7. MaxT

    MaxT Member HowtoForge Supporter

    I have removed and purged all the Rounducube files in the server, then delete the RoundCube MySQL user and database, and then reinstall Roundcube following this tutorial:

    https://www.howtoforge.com/tutorial...4-jessie-apache-bind-dovecot-ispconfig-3-1/3/


    And still I have the same issue.

    - by port 80 with some website (http://domain.com/webmail) it loads the 404 page of the website

    - by port 8080 with some website (https://domain.com:8080/webmail) there is a warning to load the server auto-self-signed certificate; I accept but then it show an apache 404 error page

    - If I try the main server (https://server.myserver.com:8080/webmail) it happens the same thing with the SSL certificate, and then showing 404 "Not Found. The requested URL /webmail was not found on this server.".

    I was thinking in some apache misconfiguration. Then I have installed a ISPC in a new VirtualBox with the same Debian 8, in order to get a clean /etc/apache2 configuration. In this Vbox I can access to /webmail without any problem.

    Then I have compared both /etc/apache2 but I cannot find any special difference.
    I have checked in the VBox there is not SquirrelMail installed, then I have deleted and purged all the Squirrel files in my server. But still it doesn't work.

    There is not any information inside /var/log/apache2/error.log. I cannot find any trace inside the Apache logs to know what happens.

    Just I see there is that moment in where it loads the SSL certificate, however the later redirection to /webmail is not understood by Apache. However, in example phpmyadmin works normally.


    Now I'm finally lost with this absurd issue of the redirection. :(

    Some idea to solve this?.
     
    Last edited: Jun 28, 2017
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your server has a /etc/apache2/conf-enabled/ folder? If yes, do you see the roundcube.conf file there or just inside the /etc/apache2/conf.d/ folder? If you have the conf-enabled folder and no roundcube.conf there, then try to move the roundcube.conf from conf.d to conf-enabled and restart apache.
     
    MaxT likes this.
  9. MaxT

    MaxT Member HowtoForge Supporter

    it works!! :)

    Cannot believe it that it was only this. No info in Apache logs, and with the debug level enabled it only showed "AH00128: File does not exist: /var/www/ispconfig/webmail" Terrible!

    thanks!:)
     

Share This Page