failure: Failed to restart httpd.service: Unit httpd.service not found.

Discussion in 'General' started by progressed36, Dec 21, 2016.

  1. progressed36

    progressed36 New Member

    Hi There,

    Im using ispconfig 3.1.1p1 on ubuntu 16.10 and bumped into a problem today.
    I was creating a new website and noticed i kept the standard apache page as landing. After looking at the vhost i noticed a warning:

    # Apache did not start after modifying this vhost file.
    # Please check file /etc/apache2/sites-available/WEBSITE.COM.vhost.err for syntax errors.


    Ok ok... so i turned on debug and run the server.sh myself to check what is happening... THe following error accured:

    21.12.2016-22:25 - WARNING - Apache did not restart after the configuration change for website WEBSITE.COM. Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/WEBSITE.COM.vhost.err
    21.12.2016-22:25 - WARNING - Reason for Apache restart failure: Failed to restart httpd.service: Unit httpd.service not found.


    The vhost.err file is correclt filed with what the vhost file should be... I need help/guidance here!

    PS: the other websites keep working... I guess till i change a setting is isponfig
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can see the error that prevented apache from starting with the new config like this:

    mv /etc/apache2/sites-available/WEBSITE.COM.vhost /etc/apache2/sites-available/WEBSITE.COM.vhost.bak
    mv /etc/apache2/sites-available/WEBSITE.COM.vhost.err /etc/apache2/sites-available/WEBSITE.COM.vhost

    and restart apache.
     
  3. progressed36

    progressed36 New Member

    Hi till, i inderstand that this works, but creating a new website after that would give me the same problem doesnt it?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No. The above should show you the error that needs to be fixed. If it does not show any error and apache starts fine, then there might be a problem with the apache service naming.
     
  5. progressed36

    progressed36 New Member

    no error. it works.

    creating a new website gives me an error again

    # Apache did not start after modifying this vhost file.
    # Please check file /etc/apache2/sites-available/WEBSITE.COM.vhost.err for syntax errors.
     
    Last edited: Dec 22, 2016
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    And you got this error?

    failure: Failed to restart httpd.service: Unit httpd.service not found.

    I wonder why he says httpd.service as it the server is a CentOS system and not an Ubuntu server.
     

Share This Page