Failure after upgrade to 2.2.14

Discussion in 'Installation/Configuration' started by EvdM, Jul 4, 2007.

  1. EvdM

    EvdM New Member

    Dear All -

    I just did an upgrade from 2.2.11 to 2.2.14 according to the normal procedure as I have always done. However, I did not seem to receive the regular queries regarding the encryption.
    Everything did seem to go well untill the end. This showed:

    All prerequisites are fulfilled.
    Here we go...

    Connected successfully to db db_ispconfig

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 799

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 807

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 812

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 822

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 839

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 1145
    Restarting some services...
    Stopping mail transport agent: Postfix.
    Starting mail transport agent: Postfix.
    Restarting ProFTPD ftp daemon.proftpd.
    .. - setting default address to 127.0.0.1
    proftpd.
    done.
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.


    Now I am no longer able to log into my ISPConfig interface using the admin account.

    Any suggestion on what to do is much appreciated, thanks!

    Erik
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    df -h

    Do you have a file with the ending .sql in the temp directory? If yes, plaese copy it to a save place together with the two tar.gz files in /tmp as we might need them to restore your installation.
     
  3. EvdM

    EvdM New Member

    Thanks for that quick response!

    df -h gives:

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 3.8G 3.4G 210M 95% /
    tmpfs 253M 0 253M 0% /dev/shm
    /dev/sdb6 1.9G 1.4G 349M 81% /var/backups
    /dev/sdb8 1.9G 637M 1.2G 36% /home
    /dev/sdc1 8.0G 5.0G 2.7G 66% /sysold


    And I do have: existing_db_07_04_2007__14_33_43.sql
    and the 2 tar.gz files.

    I did copy my /home/admispconfig and /root/ispconfig trees and the database prior to the upgrade anyway. Did not even know this was done in the process ;-)

    Hope this helps!

    Erik
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Your / partition is almost full:
    210MB are not enough to compile ISPConfig.
    Please restore your old ISPConfig installation from your backups, then clean up your hard disk and try the update again.
     
  5. EvdM

    EvdM New Member

    Thanks a lot!

    I have installed both directories, but still get the:

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!


    error. Should I restore the database also? I assumed that this did not change during the upgrade. Can you please indicate how to restore this .sql file? I have no access tot phpmyadmin and am pretty clueless without that...

    Thanks a lot!

    Erik
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The database might have been changed too, so you might have to restore it too.
     
  7. EvdM

    EvdM New Member

    I have tried to restore my database, using the instruction on:

    http://www.howtoforge.com/faq/6_4_en.html

    This failed because the the database did not seem to exist. This seems strange to me as a result of the failed upgrade, but anyway.

    I manually recreated the database db_ispconfig and tried the restore again. Unfortunately this failed with:

    ERROR 1146 at line 11: Table 'db_ispconfig.del_status' doesn't exist

    In fact, I think there are no tables at all!

    I feel that I am messing things up, rather than getting closer to a solution. If anyone can please point me in the right direction, I would be so grateful!

    Also, is there anyway to access my phpadmin without having to login into ISPConfig?

    Thanks for any help!

    Erik
     
  8. EvdM

    EvdM New Member

    I have managed to locate my phpmyadmin installation, delete and restore an old database. After this, I did the upgrade again with more spare disk space, and all went like a charm!
    I am back running with 2.2.14. Thanks for all help!
     

Share This Page