fails to write to vhosts config

Discussion in 'Installation/Configuration' started by tjd, Jan 25, 2008.

  1. tjd

    tjd New Member

    I have several hosts running on ISPConfig. all painless. All run on a 72.nnn.nnn.nnn block of ip addresses. Just grabbed a block of 67.nnn.nnn.nnn
    addresses and used one for an install.

    New domain was written into our zone files on our external dns servers and then installed via ISPConfig interface.

    I cannot get it to write an entry to Vhosts_ispconfig.conf.

    Any ideas?

    checked all apache directives for a glitch. none

    checked all the ip addresses for a typo, none

    entered the ip in etc/hosts just in case

    checked the zone files in the chroot for a glitch - server restarts clean.

    what else???

    perhaps happiness.c missing from core procs?
  2. tjd

    tjd New Member

    Doooh! Remember to enter new ip block to the network-scripts/ifcfg tables, so the the numbers can bind to the server . . . and what's worse I made the same flub a few months ago!!!
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have just one network card (eth0) in your server, ISPConfig can do the IP configuration for you when you enable it in /home/admispconfig/ispconfig/lib/

    But this will fail if you have more then one network card, that's why its disabled by default.
  4. tjd

    tjd New Member

    Great stuff . . . but still not working

    Till, thanks for that really neat tip! However I spoke too soon. Although I can now ping etc, the vhosts config file is still not being written. If I make a small change to the interface (say, alter the number of allowable databases , or something), and then save, a new date appears on the config file, but the new site is not included.???
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. tjd

    tjd New Member

    Yup . Once again, Till! I owe you a truckload of beers!

Share This Page