failed to open stream: No such file or directory in ... session.inc.php on line 243

Discussion in 'Installation/Configuration' started by offtopic, Mar 13, 2007.

  1. offtopic

    offtopic New Member

    Hello everybody.

    I just installed ISPconfig...

    I first open my session as admin/admin... and everything looks pretty good...

    But..

    When I try to add a new reseller, or client or hosting plan the following message get displayed:

    The following error occurred:
    The requested document type does not exist.

    New folder works fine...

    And new site... doesn't let do anything because there's no clients available...

    Another thing... when I try to use the top navigation menu ( Management ISP Manager DNS Manager Web-FTP ISP Invoice Tools Help Logout ) I get the following error:

    Warning: include(/home/admispconfig/ispconfig/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 243

    Warning: include() [function.include]: Failed opening '/home/admispconfig/ispconfig/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 243

    And it's like the session get messed because I can't even go back afterwards.

    Any Idea? Has anyone got a problem alike??

    I installed version 2.2.11
    Thanks in advance... if you need more info just let me know.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check with the command:

    df -h

    if you have enough space on your harddisk. Did you got any errors during installation or did you load the mysql database dump manually into the database?
     
  3. offtopic

    offtopic New Member

    df -h Output:

    Code:
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda2             5.0G  2.6G  2.2G  55% /
    udev                  498M  2.5M  495M   1% /dev
    shm                   498M     0  498M   0% /dev/shm
    /dev/sda1              38M  6.8M   30M  19% /boot
    /dev/sda3             9.9G  189M  9.2G   2% /home
    /dev/sda6             130G  310M  124G   1% /var
    
    I got some errors... but non related to the database... fortunately I copied them:

    Code:
    cp: missing destination file operand after `.orig'
    Try `cp --help' for more information.
    
    Warning: fclose(): supplied argument is not a valid stream resource in /downs/install_ispconfig/install.php on line 97
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /downs/install_ispconfig/install.php on line 1033
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /downs/install_ispconfig/install.php on line 1035
    
    Warning: fclose(): supplied argument is not a valid stream resource in /downs/install_ispconfig/install.php on line 1036
    
    Warning: fwrite(): supplied argument is not a valid stream resource in /downs/install_ispconfig/install.php on line 111
    
    Warning: fclose(): supplied argument is not a valid stream resource in /downs/install_ispconfig/install.php on line 112
    Connected successfully to MySQL server
    
    Restarting some services...
    which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
     * Caching service dependencies ...                                                                              [ ok ]
     * Starting apache2 ...                                                                                          [ ok ]
     * Stopping postfix ...                                                                                          [ ok ]
     * Starting postfix ...                                                                                          [ ok ]
    ./setup2: line 1115: [: ==: unary operator expected
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to
    


    Thanks for your reply.
     
  4. crapufish

    crapufish New Member

  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    If you are on Debian/Ubuntu, have you done
    Code:
    rm -f /bin/sh
    ln -s /bin/bash /bin/sh
    ?
     
  6. crapufish

    crapufish New Member

    I am running Ubuntu 6.10 Server and I did executed those commands (I followed step by step the "Perfect setup" tutorial).
    It still doesn't work :(
     
  7. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    The real error is probably before your posted output. As soon as you have an error during the install, the rest of the install complains about missing files, because it deletes the installation directory, thus you get a lot of errors. (maybe we can add an extra 'exit' command?)

    what's the output of
    Code:
    ls -l /root/ispconfig
    and
    Code:
    ls -l /home/admispconfig
     
  8. crapufish

    crapufish New Member

    Here is the output you requested:

    ... or it wasn't a question for me... ? :confused:

    Code:
    ~$ ls -l /root/ispconfig
    total 88
    -rwxr-xr-x  1 root root 34634 2007-03-14 10:49 cronolog
    -rwxr-xr-x  1 root root  9673 2007-03-14 10:49 cronosplit
    drwxr-xr-x 12 root root  4096 2007-03-14 10:36 httpd
    drwxr-xr-x 14 root root  4096 2007-03-14 10:49 isp
    drwxr-xr-x  6 root root  4096 2007-03-14 10:34 openssl
    drwxr-xr-x  6 root root  4096 2007-03-14 10:44 php
    drwxr-xr-x  4 root root  4096 2007-03-14 10:49 scripts
    drwxr-xr-x  4 root root  4096 2007-03-14 10:49 standard_cgis
    drwxr-xr-x  2 root root  4096 2007-03-14 10:49 sv
    -rwx------  1 root root  9389 2007-03-14 10:49 uninstall
    

    Code:
    ~$ ls -l /home/admispconfig
    total 8
    drwxr-xr-x 8 admispconfig admispconfig 4096 2007-03-14 10:49 ispconfig
    drwxr-xr-x 2 admispconfig admispconfig 4096 2007-03-14 10:49 mailstats
    
     
  9. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I was referring to the post of offtopic, but ....
    I think your problem was solved by a reinstall?
     
  10. crapufish

    crapufish New Member

    nope, it wasn't....
     
  11. offtopic

    offtopic New Member

    Ok. First of all sorry for this late reply.

    I just checked and /bin/sh points to bash.
    Code:
    lrwxrwxrwx 1 root root 4 Mar  2 17:50 /bin/sh -> bash
    
    ls -l /root/ispconfig
    Code:
    total 88
    -rwxr-xr-x  1 root root 34260 Mar 13 18:00 cronolog
    -rwxr-xr-x  1 root root  9673 Mar 13 18:00 cronosplit
    drwxr-xr-x 12 root root  4096 Mar 13 17:42 httpd
    drwxr-xr-x 14 root root  4096 Mar 13 18:00 isp
    drwxr-xr-x  6 root root  4096 Mar 13 17:41 openssl
    drwxr-xr-x  6 root root  4096 Mar 13 22:06 php
    drwxr-xr-x  4 root root  4096 Mar 13 18:00 scripts
    drwxr-xr-x  4 root root  4096 Mar 13 18:00 standard_cgis
    drwxr-xr-x  2 root root  4096 Mar 13 18:00 sv
    -rwx------  1 root root  9389 Mar 13 18:00 uninstall
    
    ls -l /home/admispconfig
    Code:
    drwxr-xr-x 8 admispconfig admispconfig 4096 Mar 13 20:42 ispconfig
    drwxr-xr-x 2 admispconfig admispconfig 4096 Mar 13 18:00 mailstats
    

    ls -l /home/admispconfig/ispconfig
    Code:
    total 40
    -rw-r--r--  1 admispconfig admispconfig   14 Mar 13 18:00 adminmail.txt
    drwxrwx---  2 admispconfig mysql        4096 Mar 13 18:00 backup
    drwxr-xr-x  4 admispconfig admispconfig 4096 Mar 13 18:00 files
    -rw-r--r--  1 admispconfig admispconfig 2116 Mar 13 22:29 ispconfig.log
    drwxr-xr-x  6 admispconfig admispconfig 4096 Mar 13 22:45 lib
    -rw-r--r--  1 root         root         1108 Mar 13 18:00 sysconf.txt
    drwxr-xr-x  2 admispconfig admispconfig 4096 Mar 13 18:00 temp
    drwxr-xr-x  8 admispconfig admispconfig 4096 Mar 13 18:00 tools
    -rw-r--r--  1 root         root          186 Mar 13 18:00 users
    drwxr-xr-x 15 admispconfig admispconfig 4096 Mar 13 20:53 web
    

    Thank you guys for your replies.
     
  12. offtopic

    offtopic New Member

  13. crapufish

    crapufish New Member

  14. offtopic

    offtopic New Member

    ├ža marche!!

    It Works... or at least it let me change admin password :p

    I'll do some tests and give you guys more feedback.

    Thanks for your replies.
     

Share This Page