Failed to install libmysql library for MYSQL client

Discussion in 'Server Operation' started by dinesh.4126, Sep 23, 2009.

  1. dinesh.4126

    dinesh.4126 New Member

    Hi,
    I am using TS-7300 board having Debain Linux3.0 distribution and Installed mysql client but when trying to install library for mysql client using apt-get install libmysqlclient15-dev its not working.
    ----------------------------------------------------------
    root@ts7300:apt-get install libmysqlclient15-dev
    Reading package lists...Done
    Building dependancy tree... Done
    you might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    binutils:depends:Lib6(>=2.7-1) but 2.3.6.ds1-13etch4 is to be installed
    libc6:depends:tzdata but it is not going to be installed
    libc6-dev:depend:libc6(=2.7-18) but 2.3.6.ds1-13etch4 is to be installed
    libmysqlclient15-dev:depend:libmysqlclient15off (>=5.0.51a-24+lenny2)but
    5.0.32-7etch3 is to be installed
    Depend :libc6(>=2.7-1) but 2.3.6.ds1-13etch4 is to be installed
    E:Unmet dependencies.Try 'apt-get -f install' with no packages.
    -------------------------------------------------------------------
    Tried 'apt-get -f install' ,not working.
    Kernel 2.4.26-ts11
    source.list :deb »ftp://ftp.us.debain.org/debain stable main contrib non-free
    Please suggest me upon this.Will I need to do changes in sources list???? file????
     
  2. falko

    falko Super Moderator ISPConfig Developer

    stable refers to Lenny (Debian 5.0) now. If you have Debian 3.0, you should replace stable with woody (I think 3.0 was Woody...).
     

Share This Page