Failed to authenticate with pure-ftpd on CentOS 5.8 (32bit) running ispconfig3

Discussion in 'Server Operation' started by rygotype, Jul 29, 2012.

  1. rygotype

    rygotype New Member

    I asked this question late last night about how I can get the latest PHP, MySQL, and phpmyadmin on my 32bit installation of CentOS 5.8.

    I was able to get PHP and MySQL back up and running successfully. I was unable to get phpmyadmin3 working, but phpmyadmin2 is still running like a champ. That's another can of worms.

    However, during the process, my pure-ftpd was removed. I reinstalled it after the new PHP and MySQL were installed by running:

    yum install pure-ftpd 
    chkconfig --levels 235 pure-ftpd on
    /etc/init.d/pure-ftpd start
    However, now I am getting authentication errors. My ispconfig3 database still exists and my ftp users are still in the proper db table for ispconfig3.
    Status: Connection established, waiting for welcome message...
    Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:   220-You are user number 1 of 50 allowed.
    Response:   220-Local time is now 12:29. Server port: 21.
    Response:   220-This is a private system - No anonymous login
    Response:   220-IPv6 connections are also welcome on this server.
    Response:   220 You will be disconnected after 15 minutes of inactivity.
    Command:    USER test_ftp
    Response:   331 User test_ftp OK. Password required
    Command:    PASS ********
    Response:   530 Login authentication failed
    Error:  Critical error
    Error:  Could not connect to server
    Log file shows this message:

    [ERROR] The SQL server seems to be down [Host '' is not allowed to connect to this MySQL server]
    To actually formulate a question, How can I fix this authentication issue?
  2. rygotype

    rygotype New Member

    To anyone who may encounter this same situation, I have found a solution. Not exactly sure WHY this simple small change would solve my problem. Don't and localhost mean the same thing? If anyone could provide a better solution, allowing for both AND localhost, that would be greatly appreciated. I'm just glad my ftp server works again.

    Edit the pureftpd-mysql.conf file

    vi /etc/pure-ftpd/pureftpd-mysql.conf
    Changed this:

    To this:
    MYSQLServer     localhost

Share This Page