Failed DNS move... gtld servers point to old IP

Discussion in 'Server Operation' started by cmawhorter, Feb 1, 2008.

  1. cmawhorter

    cmawhorter New Member

    I recently switched hosts which also switched my IP. The transition went perfectly except for DNS. DNS, also known as "black magic" has become my biggest PITA.


    -I have a wildcard record for and
    -All my domains (except one) use those two nameservers

    What I have done:

    -Setup Bind on new server with dupe config and zone files (pointing to the new IP)
    -changed all the IPs in the old zones to point to the new IP

    I thought that'd do it (not knowing anything) but it didn't. Since then I've been trying one thing after another to try to get it to work.

    -I added allow-transfer to named.conf for each IP.
    -I updated the serial in the zone files
    -I've drank lots of beer hoping that I would knock myself out long enough to have the problem fix itself

    All my sites remained reachable through the old DNS servers pointing to the new IP with the exception of my .net domains. My .nets went down completely and I had to go back to using my registrars DNS servers and manually point them to my IP. They were returning NXDOMAIN...?

    Posting here is my last resort and any help would be much appreciated. Since this would save me on two hosting bills I would be willing to throw a few US dollars your way... i know they're not worth what they used to be but c'mon.

  2. cmawhorter

    cmawhorter New Member

    I've made some changes to the config files on both servers and have gotten my master to try to initiate a transfer to the slave (the old server). It is being refused though.

    I am gettting an xfer-in error connection reset error on the old hosts log. I am going to cross my fingers and hope that now that the old host is a slave that it will eventually just work.

    If anyone has any tips I'm all ears. Thanks.
  3. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs?

    Do you have any glue records that still point to an old IP?
  4. cmawhorter

    cmawhorter New Member

    I am receiving errors in a log file on the old server.

    Feb 01 16:07:19.477 xfer-in: error: transfer of '' from failed to connect: timed out
    Feb 01 16:07:19.484 xfer-in: info: transfer of '' from end of transfer
    I don't know why the connection is bombing out. Both servers can communicate without problem.
  5. topdog

    topdog Active Member HowtoForge Supporter

    DNS transfers take place on udp port 53 ensure that a firewall is not blocking that port.

    You can debug the problem by using netcat to see if you can connect to the port
    nc -u serverip 53
  6. cmawhorter

    cmawhorter New Member

    I don't get it and I am giving up. Everything seems like it should work.

    I am just going to move my DNS back to my registrar for now.

    Thanks for all your help.

Share This Page