fail2ban postfix-sasl configuration buggy

Discussion in 'ISPConfig 3 Priority Support' started by ande, Aug 16, 2016.

  1. ande

    ande Member HowtoForge Supporter

    Hi all -
    I've been able to upgrade my Debian from 7 to 8 (jessie) under an ISPConfig 3 installation. First, fail2ban did not start but I got it to run with ssh, pop3, imap, imapssl and pop3ssl.
    But - whenever I try to start the postfix-sasl jail, I get several MBytes of logfile entries from the "date parser" every minute or even second, so I turned it off.
    Does someone have working fail2ban configs at hand?
    Or what kind of data do you need for a diagnosis? This is my jail.local:
    enabled  = true
    port     = ftp
    filter   = pureftpd
    logpath  = /var/log/syslog
    maxretry = 3
    enabled = true
    filter = dovecot-pop3imap
    action = iptables-multiport[name=dovecot-pop3imap, port="pop3,pop3s,imap,imaps", protocol=tcp]
    logpath = /var/log/mail.log
    maxretry = 5
    enabled  = false
    port     = smtp
    filter   = postfix-sasl
    logpath  = /var/log/mail.log
    maxretry = 5
    Same with postfix-sasl instead of sasl if I remember well.
    Also: I think I have Courier, not dovecot. Should I switch, BTW?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Reconfigue fail2ban as described in the perfect server tutorial for Debian 8.
  3. ande

    ande Member HowtoForge Supporter

    Worked, thanks!
    (I thought I had tried that post already - must have confused something, maybe "sasl" with "postfix-sasl"..)

Share This Page