Fail2ban not working on FC9

Discussion in 'HOWTO-Related Questions' started by nanotechgeek2, Oct 4, 2008.

  1. nanotechgeek2

    nanotechgeek2 New Member

    Hi

    I installed Fail2ban on FC9 as per the how to on http://www.howtoforge.com/preventing-brute-force-attacks-with-fail2ban-on-fedora9

    But it doesn't seem to block the authentication failure attempt even when I do a fail2ban-regex on the /var/log/messages it doesn't detect the auth failures although there are failures on it. Any idea why this is happening? I use this for SSHD auth failure events.

    Below is my jail.conf


    # "ignoreip" can be an IP address, a CIDR mask or a DNS host. Fail2ban will not
    # ban a host which matches an address in this list. Several addresses can be
    # defined using space separator.
    ignoreip = 127.0.0.1 192.168.8.0/24

    # "bantime" is the number of seconds that a host is banned.
    bantime = 7200

    # A host is banned if it has generated "maxretry" during the last "findtime"
    # seconds.
    findtime = 600

    # "maxretry" is the number of failures before a host get banned.
    maxretry = 3

    # "backend" specifies the backend used to get files modification. Available
    # options are "gamin", "polling" and "auto". This option can be overridden in
    # each jail too (use "gamin" for a jail and "polling" for another).
    #
    # gamin: requires Gamin (a file alteration monitor) to be installed. If Gamin
    # is not installed, Fail2ban will use polling.
    # polling: uses a polling algorithm which does not require external libraries.
    # auto: will choose Gamin if available and polling otherwise.
    backend = auto

    # This jail corresponds to the standard configuration in Fail2ban 0.6.
    # The mail-whois action send a notification e-mail with a whois request
    # in the body.

    [ssh-iptables]

    enabled = true
    filter = sshd
    action = iptables[name=SSH, port=ssh, protocol=tcp]
    sendmail-whois[name=SSH, dest=me@me.com, sender=fail2ban-vpn@me.com]
    logpath = /var/log/secure
    maxretry = 3
     
  2. falko

    falko Super Moderator

    fail2ban is checking /var/log/secure instead of /var/log/messages.
     
  3. nanotechgeek2

    nanotechgeek2 New Member

    OK.. I changed it to /var/log/messages.. Will get back to you if anything happens.
     
  4. nanotechgeek2

    nanotechgeek2 New Member

    I did as what falko told me and it seems to work now ..when I do a fail2ban-regex it does capture the auth fail events. thanks falco ..so the correction is

    point log to be scanned to /var/log/messages
     

Share This Page