fail2ban not starting

Discussion in 'Installation/Configuration' started by Taleman, Apr 28, 2017.

  1. Taleman

    Taleman Member

    Debian GNU/Linux 8.7 (jessie)
    ISPConfig 3.1.2
    Just noticed fail2ban does not start. Server is installed following Perfect Server guide, and I just checkec the configuration files, they look to me identical to the ones in guide.
    Code:
    root@ispc5:/etc/fail2ban/filter.d# service fail2ban stop
    root@ispc5:/etc/fail2ban/filter.d# service fail2ban start
    root@ispc5:/etc/fail2ban/filter.d# service fail2ban status
    ‚óŹ fail2ban.service - LSB: Start/stop fail2ban
       Loaded: loaded (/etc/init.d/fail2ban)
       Active: active (exited) since pe 2017-04-28 14:27:33 EEST; 2s ago
      Process: 19457 ExecStop=/etc/init.d/fail2ban stop (code=exited, status=0/SUCCESS)
      Process: 19485 ExecStart=/etc/init.d/fail2ban start (code=exited, status=0/SUCCESS)
    
    huhti 28 14:27:33 ispc5.antenniserveri.fi fail2ban[19485]: Starting authentication failure monitor: fail2banERROR  Error in action definition iptables-multiport[name=dovecot-pop3imap,
    huhti 28 14:27:33 ispc5.antenniserveri.fi fail2ban[19485]: ERROR  Errors in jail 'dovecot-pop3imap'. Skipping...
    huhti 28 14:27:33 ispc5.antenniserveri.fi fail2ban[19485]: failed!
    huhti 28 14:27:33 ispc5.antenniserveri.fi systemd[1]: Started LSB: Start/stop fail2ban.
    root@ispc5:/etc/fail2ban/filter.d#
    
    ISPConfig Control Panel says fail2ban is not installed on this host.
    fail2ban.log files are empty.
    If there is an error in configuration files, how to find out what error and where?
     
  2. sjau

    sjau Local Meanie Moderator

    Code:
    huhti 28 14:27:33 ispc5.antenniserveri.fi fail2ban[19485]: Starting authentication failure monitor: fail2banERROR Error in action definition iptables-multiport[name=dovecot-pop3imap,
    huhti 28 14:27:33 ispc5.antenniserveri.fi fail2ban[19485]: ERROR Errors in jail 'dovecot-pop3imap'. Skipping...
    
     
  3. Taleman

    Taleman Member

    Found it at last. One line had got an extra newline in the middle. I copypasted those lines, strange.
     

Share This Page