Fail2Ban not starting, nothing in logs?

Discussion in 'HOWTO-Related Questions' started by Gigaquad, Jul 14, 2012.

  1. Gigaquad

    Gigaquad New Member

    [SOLVED] Fail2Ban not starting, nothing in logs?

    Hi everyone! I'm trying to get this tut up and running for a production server and I can't seem to figure out what's wrong with my fail2ban install.

    Here's the HowTo:
    Perfect Server Ubuntu 12.04 with Apache, Bind, Dovecot, and ISPConfig
    http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p5

    I did not install jailkit because I don't expect to have chrooted ssh (or any ssh) access to this server.

    Other than that it's all according to the instructions.

    My question is first, where can I find a detailed log for fail2ban?
    And second, is jailkit required for this setup? I have heard it causes problems later on down the road.
     
    Last edited: Jul 14, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

    It's in the /var/log/ directory.


    It's not required if you don't want to offer chrooted SSH.
     
  3. Gigaquad

    Gigaquad New Member

    The log says:

    stopping all jails
    Jail 'ssh' stopped
    Exiting Fail2ban
    Changed logging target to /var$
    Creating new jail 'ssh'
    Jail 'ssh' uses Gamin
    Added logfile = /var/log/auth.$
    Set maxRetry = 6
    Set findtime = 600
    Set banTime = 600
    Jail 'ssh' started

    With that last line I think it's running? How would I stat it to see if it's running?

    EDIT: Restart fixed the problem. Now I feel foolish. :)
     
    Last edited: Jul 14, 2012

Share This Page