Fail to test Apach2

Discussion in 'Server Operation' started by satimis, Nov 13, 2006.

  1. satimis

    satimis New Member

    Hi folks,

    Apache2

    First test after installation failed. This is a test without Domain.

    On firefox ran "http://127.0.0.1/". It hung there for prolonged time
    without the default page popup.


    $ ps -ef | egrep /apache2
    Code:
    root      5064     1  0 11:26 ?        00:00:00 /usr/sbin/apache2 -k
    start -DSSL
    www-data  5066  5064  0 11:26 ?        00:00:00 /usr/sbin/apache2 -k
    start -DSSL
    www-data  5067  5064  0 11:26 ?        00:00:00 /usr/sbin/apache2 -k
    start -DSSL
    www-data  5068  5064  0 11:26 ?        00:00:00 /usr/sbin/apache2 -k
    start -DSSL
    www-data  5069  5064  0 11:26 ?        00:00:00 /usr/sbin/apache2 -k
    start -DSSL
    www-data  5070  5064  0 11:26 ?        00:00:00 /usr/sbin/apache2 -k
    start -DSSL
    satimis   5077  4836  0 11:30 pts/2    00:00:00 grep -E /apache2
    
    $ cat /var/log/apache2/error.log
    Code:
    ....
    [Thu Oct 19 03:36:00 2006] [notice] caught SIGTERM, shutting down
    [Thu Oct 19 03:36:57 2006] [notice] Apache/2.0.55 (Ubuntu) PHP/5.1.2
    configured -- resuming normal operations
    [Thu Oct 19 03:39:44 2006] [notice] caught SIGTERM, shutting down
    [Thu Oct 19 03:40:41 2006] [notice] Apache/2.0.55 (Ubuntu) PHP/5.1.2
    configured -- resuming normal operations
    [Thu Oct 19 03:41:42 2006] [notice] caught SIGTERM, shutting down
    [Thu Oct 19 03:42:39 2006] [notice] Apache/2.0.55 (Ubuntu) PHP/5.1.2
    configured -- resuming normal operations
    [Thu Oct 19 04:01:11 2006] [notice] caught SIGTERM, shutting down
    
    $ cat /etc/apache2/ports.conf
    Code:
    Listen 80
    Listen 44
    
    Are there other basic test on Apache2? TIA


    Edit-1: * * *

    Ubuntu-606.1-LAMP-server-amd64

    What shall I put on /etc/hosts.conf ?

    Original final was;
    Code:
    order hosts,bind
    multi on
    Edited it as;
    Code:
    order hosts,bind
    multi on
    127.0.0.l localhost.localdomain localhost
    On running
    sudo /etc/init.d/apache2 restart
    Code:
    /etc/host.conf: line 3: bad command `127.0.0.l localhost.localdomain localhost'
     * Forcing reload of apache 2.0 web server...        [ok]
    It complained.


    Edit-2: * * *

    $ ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:16502 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16479 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:5537284 (5.2 MiB)  TX bytes:2172880 (2.0 MiB)
              Interrupt:217 Base address:0xe000
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:58.152.160.229  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:16340 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16311 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:5168014 (4.9 MiB)  TX bytes:1808648 (1.7 MiB)
    



    B.R.
    satimis
     
    Last edited: Nov 14, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    This doesn't look ok. There's no loopback interface (127.0.0.1). What's in /etc/hosts? And please undo your changes to /etc/hosts.conf.
     
  3. satimis

    satimis New Member

    Hi falko,

    No, without lo. It took me sometime to discover it.

    $ cat /etc/hosts
    Code:
    127.0.0.1       localhost.localdomain   localhost
    127.0.1.1       ubuntu
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    Yes

    original /etc/hosts.conf
    Code:
    order hosts,bind
    multi on
    
    I was not allowed to add anything here. Tks.

    B.R.
    satimis
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/network/interfaces?

    What does the output of
    Code:
    ifconfig
    look like after you restart the network?
    Code:
    /etc/init.d/networking restart
     
  5. satimis

    satimis New Member

    Hi falko,

    Before:-
    $ sudo ifconfig
    Code:
    Password:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:859323 errors:0 dropped:0 overruns:0 frame:0
              TX packets:452522 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:1297342793 (1.2 GiB)  TX bytes:34920134 (33.3 MiB)
              Interrupt:217 Base address:0xe000
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:218.250.36.47  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:859012 errors:0 dropped:0 overruns:0 frame:0
              TX packets:452205 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1278425799 (1.1 GiB)  TX bytes:24961764 (23.8 MiB)
    $ sudo /etc/init.d/networking restart
    Code:
     * Reconfiguring network interfaces... /etc/network/interfaces:19: misplaced option
    ifdown: couldn't read interfaces file "/etc/network/interfaces"
    /etc/network/interfaces:19: misplaced option
    ifup: couldn't read interfaces file "/etc/network/interfaces"         [fail]
    It failed.

    $ sudo ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:859639 errors:0 dropped:0 overruns:0 frame:0
              TX packets:452868 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:1297543557 (1.2 GiB)  TX bytes:35031829 (33.4 MiB)
              Interrupt:217 Base address:0xe000
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:218.250.36.47  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:859317 errors:0 dropped:0 overruns:0 frame:0
              TX packets:452540 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1278619193 (1.1 GiB)  TX bytes:25065759 (23.9 MiB)
    
    Looks the same.

    $ cat /etc/network/interfaces
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    address 127.0.0.1
    netmask 255.0.0.0
    auth eth0
    iface eth0 inet dhcp
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    
    # added by pppoeconf
    auto eth0
    
    pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf


    Edit: * * *

    Just installed "webmin-1.300 on the server anticipating it will ease my work on configuration.

    $ whereis webmin
    webmin: /etc/webmin /usr/local/webmin

    I download the package "webmin-1.300.tar.gz" on its site, because Ubuntu repositories did not offer this package.

    Ran;
    $ sudo /etc/init.d/firewall stop
    Code:
    Password:
    Removing all iptables rules:  [End of flush]
    to stop iptables.

    Started Firefox;
    http://localhost:10000/
    http://admin:10000/
    hppt://satimis:10000/

    all no response, only hanging there. Webmin failed to start same situation as Apache2.

    B.R.
    satimis
     
    Last edited: Nov 16, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    Please modify /etc/network/interfaces so that it looks like this:

    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
          address 127.0.0.1
          netmask 255.0.0.0
    
    auth eth0
    iface eth0 inet dhcp
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    Then restart your network:
    Code:
    /etc/init.d/networking restart
     
  7. satimis

    satimis New Member

    Hi falko,

    I tried it before without result. Now I test it again.

    $ cat /etc/network/interfaces
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
         address 127.0.0.1
         netmask 255.0.0.0
    
    auth eth0
    iface eth0 inet dhcp
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    $ sudo /etc/init.d/networking restart
    Code:
    Password:
    [email protected]:~$ sudo /etc/init.d/networking restart
     * Reconfiguring network interfaces... Plugin rp-pppoe.so loaded.
                                                                             [ ok ]
    $ su
    Password:

    # /etc/init.d/firewall stop
    Code:
    Removing all iptables rules:  [End of flush]
    # firefox
    Started browser.

    http://127.0.0.1
    http://localhost
    http://localhost:10000
    http://admin:10000
    http://satimis:10000

    all can't work only hanging there. Default page of Apache2 and Webmin failed to start.


    Edit: * * *

    After deleting following lines on /etc/network/intertaces
    Code:
    auto eth0
    
    pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
    
    On next reboot, eth0 was not up.

    $ sudo pppoeconf
    can't find it. Failed to make broadband connectiong.

    If only deleting;
    Code:
    pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
    
    $ sudo /etc/init.d/networking restart
    Code:
     * Reconfiguring network interfaces... Plugin rp-pppoe.so loaded.
    Internet Systems Consortium DHCP Client V3.0.3
    Copyright 2004-2005 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/products/DHCP
    
    Listening on LPF/eth0/00:13:d4:fe:da:87
    Sending on   LPF/eth0/00:13:d4:fe:da:87
    Sending on   Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
                                                                             [ ok ]
    On both cases
    $ sudo ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1865 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1870 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:1508341 (1.4 MiB)  TX bytes:280394 (273.8 KiB)
              Interrupt:217 Base address:0xe000
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:219.78.150.175  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:1805 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1792 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1464961 (1.3 MiB)  TX bytes:236396 (230.8 KiB)
    
    lo still missing.


    B.R.
    satimis
     
    Last edited: Nov 17, 2006
  8. falko

    falko Super Moderator ISPConfig Developer

    Please try
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    auth eth0
    iface eth0 inet dhcp
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    in /etc/network/interfaces and restart the network. What's the output of
    Code:
    ifconfig
    then?
     
  9. satimis

    satimis New Member

    Hi falko

    Oh sorry, I forgot to mention. The output was the same, lo missing.

    I did it again.

    $ cat /etc/network/interfaces
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
         address 127.0.0.1
         netmask 255.0.0.0
    
    auth eth0
    iface eth0 inet dhcp
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    
    # added by pppoeconf
    #auto eth0
    
    #pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
    
    $ sudo /etc/init.d/networking restart
    Code:
     * Reconfiguring network interfaces... Plugin rp-pppoe.so loaded.      [ ok ]
    
    $ ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1171 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1171 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:1042874 (1018.4 KiB)  TX bytes:265059 (258.8 KiB)
              Interrupt:217 Base address:0xe000
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:219.79.146.219  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:1154 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1146 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1016396 (992.5 KiB)  TX bytes:238743 (233.1 KiB)
    
    Also I forgot to mention "mysql" failed to restart.

    $ sudo /etc/init.d/mysql restart
    Code:
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.
    .
    .
    .
    ...failed or took more than 6s.
            Please take a look at the syslog.
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
    Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
    
    mysqld.sock lost.

    $ ls /var/run/mysqld/ | grep mysqld.sock
    No printout

    I have to reinstate the original /etc/network/interfaces.
    re-ran "$ sudo /etc/init.d/networking restart"
    rebooted PC to get "mysqld.sock" back


    Edit-1: * * *

    New discovery.

    1) commented out the line "#pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf"
    2) ran "/etc/init.d/networking restart"
    2) ran "/etc/init.d/mysql restart" confirming uable to start "mysql", missing mysqld.sock
    4) ran
    $ ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1096 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1126 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:903613 (882.4 KiB)  TX bytes:229418 (224.0 KiB)
              Interrupt:217 Base address:0xe000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:149 errors:0 dropped:0 overruns:0 frame:0
              TX packets:149 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:24120 (23.5 KiB)  TX bytes:24120 (23.5 KiB)
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:219.79.146.231  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:1064 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1045 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:878215 (857.6 KiB)  TX bytes:198902 (194.2 KiB)
    
    lo was there

    started Firefox as User
    evoked "http://localhost" or "127.0.0.1" on it. Apache default page started.
    evoked "http://localhost:10000/" on it. Admin page of Webmin still failed to start
    Is the command "http://localhost:10000/" being correct ???


    Edit-2 * * *

    Something strange happened here.

    1)
    Rebooted PC. MySQL failed to start displayed on text scrolling

    2)
    Login as User and started Xfce4 desktop

    3)
    Ran
    $ ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:110 errors:0 dropped:0 overruns:0 frame:0
              TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:9408 (9.1 KiB)  TX bytes:14961 (14.6 KiB)
              Interrupt:217 Base address:0xe000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:78 errors:0 dropped:0 overruns:0 frame:0
              TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:7049 (6.8 KiB)  TX bytes:7049 (6.8 KiB)
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:219.79.145.94  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:98 errors:0 dropped:0 overruns:0 frame:0
              TX packets:142 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:6462 (6.3 KiB)  TX bytes:9261 (9.0 KiB)
    
    showing ISP connected automatically without running "pppoeconf"
    lo was there.

    3)
    $ sudo ping -c 3 yahoo.com (please see my next posting) * * * * *
    Password:
    the mouse point hung here. It seemed something blocking the network.

    4)
    Started Firefox as User and evoked "http://localhost". Apache default page displayed

    5)
    evoked "http://localhost:10000/" can't display webmin admin page.
    Warning: Firefox can't establish a connection to the server at localhost:10000.

    6)
    Ran "sudo pppoeconf" saying NIC can't be detected.

    7)
    Edited "/etc/network/interfaces" to uncomment the line "pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf"

    8)
    Ran "sudo /etc/init.d/networking restart"

    9)
    Ran "sudo pppoeconf"
    This time NIC can be detected.

    10)
    $ ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:327 errors:0 dropped:0 overruns:0 frame:0
              TX packets:435 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:29967 (29.2 KiB)  TX bytes:42010 (41.0 KiB)
              Interrupt:217 Base address:0xe000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:81 errors:0 dropped:0 overruns:0 frame:0
              TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:7205 (7.0 KiB)  TX bytes:7205 (7.0 KiB)
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:220.246.238.134  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:15 errors:0 dropped:0 overruns:0 frame:0
              TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1842 (1.7 KiB)  TX bytes:1131 (1.1 KiB)
    
    lo was there.

    11)
    Apache default page can be started but not the admin page of webmin.

    12)
    $ sudo ping -c 3 yahoo.com
    Code:
    PING yahoo.com (216.109.112.135) 56(84) bytes of data.
    64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=1 ttl=56 time=276 ms
    64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=2 ttl=57 time=275 ms
    64 bytes from w2.rc.vip.dcn.yahoo.com (216.109.112.135): icmp_seq=3 ttl=57 time=275 ms
    
    --- yahoo.com ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2010ms
    rtt min/avg/max/mdev = 275.559/275.885/276.524/0.756 ms
    
    showing broadband connected and working

    13)
    MySQL still failed to start, mysqld.sock missing.


    B.R.
    satimis
     
    Last edited: Nov 18, 2006
  10. satimis

    satimis New Member

    Solved

    Hi falko,

    Further to my late posting.

    Final /etc/network/interfaces
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
         address 127.0.0.1
         netmask 255.0.0.0
    
    auth eth0
    iface eth0 inet dhcp
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    
    # added by pppoeconf
    auto eth0
    
    #pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
    
    $ sudo ping -c 3 yahoo.com
    failed, web site not found

    "Ping IP address" worked

    $ sudo nano /etc/resolv.conf
    Code:
    search com
    nameserver 204.11.126.131
    nameserver 64.125.134.133
    nameserver 64.125.134.132
    nameserver 208.185.179.218
    
    added follows on it;
    Code:
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    
    Now connection to Internet worked on URL

    Started Firefox and evoked "localhost" on it displaying default page of
    Apache, indicating "installation of the Apache web server software on
    this system was successful"

    "http://localhost:10000/" still failed. Can't start the admin page of
    webmin


    $ sudo /etc/init.d/mysql start
    Failed. "mysqld.sock" not found

    $ sudo cat /etc/mysql/my.cnf | grep address
    Code:
    bind-address            = 192.168.1.20
    Edited /etc/mysql/my.cnf changing "bind-address" as
    Code:
    bind-address   =172.0.0.1
    $ sudo /etc/init.d/mysql start
    Now mysql started without problem

    $ sudo netstat -tap | grep mysql
    Code:
    tcp        0      0 localhost.localdo:mysql *:*
    LISTEN     5646/mysqld 
    Rebooted PC to recheck above.
    - "Ping URL" worked
    - mysql started at boot
    - default page of Apache displayed on browser.
    - login mysql with "mysql -u root -p" worked


    $ ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:13:D4:FE:DA:87
              inet6 addr: fe80::213:d4ff:fefe:da87/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1160 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1111 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:897681 (876.6 KiB)  TX bytes:211760 (206.7 KiB)
              Interrupt:217 Base address:0xe000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:92 errors:0 dropped:0 overruns:0 frame:0
              TX packets:92 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:7961 (7.7 KiB)  TX bytes:7961 (7.7 KiB)
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:219.78.150.31  P-t-P:219.78.150.254  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:1127 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1060 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:870837 (850.4 KiB)  TX bytes:181250 (177.0 KiB)
    

    But still failed to start the admin page of webmin


    It is not an easy job. There is still a long way for me to explore.

    I think my problem is too many servers on the same PC plus I'm inexperienced on server-building and server-admin.

    Tks.


    B.R.
    satimis
     
    Last edited: Nov 18, 2006
  11. falko

    falko Super Moderator ISPConfig Developer

    Please try https://localhost:10000 instead.
     
  12. satimis

    satimis New Member

    hI falko,

    Still the same, no admin page displayed.

    DHCP found not started.

    $ sudo /etc/init.d/dhcp start
    Code:
    Starting DHCP server: dhcpd.
    
    $ cat /etc/dhcpd.conf
    Code:
    #
    # Sample configuration file for ISC dhcpd for Debian
    #
    # $Id: dhcpd.conf,v 1.4.2.2 2002/07/10 03:50:33 peloy Exp $
    
    default-lease-time 600;
    max-lease-time 7200;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.1.255;
    option routers 192.168.1.254;
    option domain-name-servers 192.168.1.1, 192.168.1.2;
    option domain-name "mydomain.org";
    
    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.10 192.168.1.100;
    range 192.168.1.150 192.168.1.200;
    }
    
    Add following 2 lines on /etc/dhcpd.conf
    Code:
    ddns-update-style interim;
    ignore client-updates;
    $ cat /etc/dhcpd.conf
    Code:
    #
    # Sample configuration file for ISC dhcpd for Debian
    #
    # $Id: dhcpd.conf,v 1.4.2.2 2002/07/10 03:50:33 peloy Exp $
    ddns-update-style interim;
    ignore client-updates;
    
    default-lease-time 600;
    max-lease-time 7200;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.1.255;
    option routers 192.168.1.254;
    option domain-name-servers 192.168.1.1, 192.168.1.2;
    option domain-name "mydomain.org";
    
    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.10 192.168.1.100;
    range 192.168.1.150 192.168.1.200;
    }
    
    $ sudo /etc/init.d/dhcp start
    Code:
    Starting DHCP server: dhcpd.
    
    Still can't start admin page with
    https://localhost:10000
    http://localhost:10000
    https://127.0.0.1:10000
    http://127.0.0.1:10000

    on Firefox started as root.


    B.R.
    satimis
     
  13. satimis

    satimis New Member

    Webmin problem - SOLVED

    Hi falko,

    Problem solved as follows;

    $ sudo /etc/webmin/start
    Password:
    Code:
    Starting Webmin server in /usr/local/webmin
    $ sudo ps -ef | grep webmin
    Code:
    root      5506     1  0 18:55 ?        00:00:00 /usr/bin/perl /usr/local/webmin/miniserv.pl /etc/webmin/miniserv.conf
    satimis   5527  5486  0 18:56 pts/2    00:00:00 grep webmin
    
    Started Firefox and evoked "http://localhost:10000" on it to start Login page

    After login satimis, Admin page started.


    B.R.
    satimis
     

Share This Page