Fail to mount remote NFS server

Discussion in 'Server Operation' started by satimis, Apr 19, 2008.

  1. satimis

    satimis New Member

    Hi folks,


    Server A
    Ubuntu server 6.06.4 amd64
    hostname=lampserver
    IP add - 192.168.0.52

    Server B
    Ubuntu server 7.04 amd64
    hostname=mail.satimis.com
    IP add - 192.168.0.10


    They are connected to the same router.

    Server A

    $ sudo /etc/init.d/nfs-kernel-server start
    Code:
     * Exporting directories for NFS kernel daemon...                        [ ok ] 
     * Starting rpc nfsd...                                                  [ ok ] 
     * Starting rpc mountd...                                                [ ok ] 

    Server B
    $ sudo /etc/init.d/nfs-kernel-server start
    Code:
     * Exporting directories for NFS kernel daemon...                               exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "*:/ubuntu".
      Assuming default behaviour ('subtree_check').
      NOTE: this default will change with nfs-utils version 1.1.0
    exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specified for export "*:/home".
      Assuming default behaviour ('subtree_check').
      NOTE: this default will change with nfs-utils version 1.1.0
                                                                             [ OK ]
     * Starting NFS kernel daemon                                            [ OK ] 
    
    Here it seems having problem. Please advise where to check and how to fix the problem


    Server A

    $ sudo mount mail.satimis.com:/ubuntu /mnt
    Code:
    mount to NFS server 'mail.satimis.com' failed: server is down.
    

    B.R.
    satimis
     
    Last edited: Apr 25, 2008
  2. zcworld

    zcworld New Member

    maybe this will help or not
    if u do an ping
    ping mail.satimis.com
    what IP address do you get
    an LAN IP address of the box or your WAN IP


    if you getting your WAN IP

    on the www host box
    vi /etc/hosts

    <IP> <TAB> mail.satimis.com

    save it and reping
    and see if it will fix the failing to mount problem
     
  3. satimis

    satimis New Member

    Hi zcworld,


    Thanks for your advice.


    $ ping mail.satimis.com
    Code:
    PING mail.satimis.com (220.232.213.178) 56(84) bytes of data.
    64 bytes from 220.232.213.178: icmp_seq=1 ttl=150 time=1.24 ms
    64 bytes from 220.232.213.178: icmp_seq=2 ttl=150 time=0.664 ms
    64 bytes from 220.232.213.178: icmp_seq=3 ttl=150 time=0.715 ms
    
    WAN IP


    Sorry I don't follow. Whether LAN IP or WAN IP


    $ cat /etc/hosts
    Code:
    127.0.0.1       localhost.localdomain   localhost
    192.168.0.10    mail.satimis.com        mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    

    Do I need reboot PC after changing /etc/hosts
    ? ? ?


    TIA


    B.R.
    satimis
     
  4. zcworld

    zcworld New Member

    no reboot needed when editing the hosts file

    ok on the WAN / LAN

    if your using
    server1.mysite.com

    but you dont have setup the server1.mysite.com = 10.10.10.1 in the hosts file
    it will try to find the IP

    in that case it will be trying the public IP
     
  5. satimis

    satimis New Member

    Tried 3 setup on /etc/hosts in respect of the line
    Code:
    220.232.213.178   mail.satimis.com   mail
    
    OR
    Code:
    192.168.0.10   mail.satimis.com   mail
    

    OR nothing there
    Code:
                    mail.satimis.com   mail
    
    ping still find the WAN, 220.232.213.178


    All
    $ sudo mount mail.satimis.com:/ubuntu /mnt
    Code:
    mount to NFS server 'mail.satimis.com' failed: server is down
    

    satimis
     
  6. zcworld

    zcworld New Member

    check the firewall and make sure its letting the NFS port out
    and restart the NFS server on the remote box

    ( i take it that you done the /etc/export file as well
    there you set the IP / RW or RO settings )
     
  7. satimis

    satimis New Member

    On Mail Server - Server B

    Edit /etc/rc.local and add following lines on "OUTPUT
    Code:
    iptables -A OUTPUT -p udp --dport 2049 -j ACCEPT # nfs port
    iptables -A OUTPUT -p tcp --dport 2049 -j ACCEPT # nfs port
    
    Remark: I'm not very clear of "udp" function. Just add this line as well. Is "2049" the correct port?

    $ sudo /etc/init.d/portmap restart
    Code:
     * Stopping portmap daemon...                     [ OK ] 
     * Starting portmap daemon...                      [ OK ] 
    
    $ sudo /etc/init.d/nfs-kernel-server restart
    Code:
     * Stopping NFS kernel daemon                                            [ OK ] 
     * Unexporting directories for NFS kernel daemon...                      [ OK ] 
     * Exporting directories for NFS kernel daemon...                               
    exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specif
    ied for export "*:/ubuntu".
      Assuming default behaviour ('subtree_check').
      NOTE: this default will change with nfs-utils version 1.1.0
    exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specif
    ied for export "*:/home".
      Assuming default behaviour ('subtree_check').
      NOTE: this default will change with nfs-utils version 1.1.0
                                                                             [ OK ]
     * Starting NFS kernel daemon                                            [ OK ] 
    

    $ sudo /etc/init.d/nfs-common restart
    Code:
     * Stopping NFS common utilities                                         [ OK ] 
     * Starting NFS common utilities                                         [ OK ] 
    
    I'm NOT very clear whether I need to run both of them (above), OR "sudo /etc/init.d/nfs-common" ONLY.


    Do I need caring the WARNING there?


    Still fail to mout;
    $ sudo mount mail.satimis.com:/ubuntu /mnt
    Code:
    mount to NFS server 'mail.satimis.com' failed: server is down.
    
    Also tried "stop iptables running" with same result.


    On Server B - Mail Server

    $ cat /etc/exports
    Code:
    /ubuntu  *(ro,sync,no_root_squash)
    /home    *(rw,sync,no_root_squash)
    

    On Server A
    $ cat /etc/exports
    Code:
    # /etc/exports: the access control list for filesystems which may be exported
    #               to NFS clients.  See exports(5).
    /ubuntu  *(ro,sync,no_root_squash)
    /home    *(rw,sync,no_root_squash)
    

    Sorry I don't follow. Pls explain in more detail. Thanks


    B.R.
    satimis
     
    Last edited: Apr 25, 2008
  8. zcworld

    zcworld New Member

    try this

    /ubuntu 192.168.0.52(ro,sync,no_root_squash)
    /home 192.168.0.52(rw,sync,no_root_squash)

    on the server b mail.satimis.com


    than " exportfs -ra "

    than retry

    check out this http://nfs.sourceforge.net/nfs-howto/
    page 4
    this is what i use to get my NFS up and working
     
  9. satimis

    satimis New Member

    Edit /etc/exports (Mail Server)

    $ cat /etc/exports
    Code:
    /ubuntu 192.168.0.52(ro,sync,no_root_squash)
    /home   192.168.0.52(rw,sync,no_root_squash)
    

    $ sudo exportfs -ra
    Code:
    exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.0.52:/ubuntu".
      Assuming default behaviour ('subtree_check').
      NOTE: this default will change with nfs-utils version 1.1.0
    exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.0.52:/home".
      Assuming default behaviour ('subtree_check').
      NOTE: this default will change with nfs-utils version 1.1.0
    
    Do I need to care the warning?


    Still fail.

    $ sudo mount mail.satimis.com:/ubuntu /mnt
    Code:
    Password:
    mount to NFS server 'mail.satimis.com' failed: server is down.
    

    Thanks. I'll go through it first and come back latter


    B.R.
    satimis
     

Share This Page