Fail to boot to SuSE desktop after kernel upgrade

Discussion in 'Kernel Questions' started by sean_zhang, Aug 13, 2007.

  1. sean_zhang

    sean_zhang New Member

    I downloaded the kernel from and tried to install it on my system (old kernel is 2.6.12) following the guide on, but after when it's done, I got the following messages when my computer restarts.

    TCP: Hash tables configured (established 1310702 bind 65536)
    TCP reno registered
    Checking if image is initramfs... it is
    Freeing initrd memory: 2342k freed
    apm: BIOS not found
    audit: initializing netlink socket (disabled)
    audit(1187003001.692.1): initialized
    highmem bounce pool size: 64 pages
    Total HugeTLB memory allocated, 0
    VFS: Disk quotas dquot_6.5.1
    Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
    io scheduler noop regitered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered (default)
    assign_interrupt_mode Found MSI capability
    assign_interrupt_mode Found MSI capability
    vesafb: framebuffer at 0xe0000000, mapped to 0xf8880000, using 1875k, total 16384k
    vesafb: mode is 800x600x16, linelength=1600, pages=16
    vesafb: protected mode interface info at c000:a026
    vesafb: pmi:set display start=c00ca0b0, set palette=c00ca16e
    vesafb: scrolling: redraw
    vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
    Console: switching to color frame buffer device 100x37
    fb0: VESA VGA frame buffer device
    isapnp: Scanning for pnp cards..
    isapnp: no pnp device found
    Real Time Clock Driver v1.12ac
    Serial: 8250/16550 driver $ Revision: 1.90 $ 4 ports, IRQ sharing enabled
    00:09: ttys0 at I/O 0x3f8 (irq=4) is a 16550A
    Floppy device(s): fd0 is 1.44M
    Clocksource tsc unstable (delta=5993995 1181 ns)

    After the message, the system seems hang up.
    Can you please tell me what is wrong with my system?

    My hardware configuration:
    Dell notebook D631
    (XPress 1270 chipset)
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you create a ramdisk of your new kernel? What's in /boot/grub/menu.lst?

    Did you use the configuration of the old working kernel to compile the new one?
  3. sean_zhang

    sean_zhang New Member

    Here is content of my menu.lst file:

    # Modified by YaST2. Last modification on 一 8月 13 08:07:02 CST 2007
    color white/blue black/light-gray

    default 2
    timeout 8
    gfxmenu (hd0,5)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title SUSE Linux Enterprise Desktop 10
    root (hd0,5)
    kernel /boot/vmlinuz
    splash=silent showopts
    initrd /boot/initrd

    title SuSE Test
    root (hd0,5)
    kernel /boot/vmlinuz-
    splash=silent showopts
    initrd /boot/initrd-

    ###Don't change this comment - YaST2 identifier: Original name: windows###

    title Windows
    chainloader (hd0,1)+1

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- SUSE Linux Enterprise Desktop 10
    root (hd0,5)
    kernel /boot/vmlinuz
    vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3

    I did load the old config file that worked with my old kernel file before I compiled the new kernel: config-
    But I am not sure if the old config file is loaded successfully. No errors or warnings pop up.
  4. sean_zhang

    sean_zhang New Member

    I've got another question:

    I also tried to patch my old kernel 2.6.16 using file patch-2.6.22
    patch -p1 < patch-2.6.22

    But nothing changed after the patch was installed. Why?
    Is it possible to upgrade kernel in this way?
  5. falko

    falko Super Moderator ISPConfig Developer

    You can apply the patch-2.6.22 to the 2.6.21 kernel, but not to 2.6.16.
  6. sean_zhang

    sean_zhang New Member

    It seems to be the problem of the new kernel

    I tried to install the OpenSuSE 10.3 Beta (Kernel version on my notebook yesterday, and I met the following problems:
    A. The installation process is quite slow. It spend over 10 min (probably much longer) to detect and active hardwares.
    B. The hard disk is not found.

    Then I tried to boot SuSE10 w/ the newly installed kernel, which is from, and I found that after 10 (or 20? or even longer) min, the system reports the following messages:
    PS: SuSE10 is installed in the partition sda5

    I wonder if anybody has met this problem when using kernel 2.6.22.

    The hardware configuration of my notebook:
    CPU: AMD 64 X2 TL-56
    Chipset: AMD XPress 1270
    Hard drive: Toshiba SATA 60G

Share This Page