Fail ISPConfig installation

Discussion in 'Installation/Configuration' started by Enrique García, Sep 20, 2017.

  1. Enrique García

    Enrique García New Member HowtoForge Supporter

    Hi I have next MariaDB version:
    MariaDB [(none)]> SHOW VARIABLES LIKE "%version%";
    +-------------------------+---------------------------------+
    | Variable_name | Value |
    +-------------------------+---------------------------------+
    | innodb_version | 5.7.19 |
    | protocol_version | 10 |
    | slave_type_conversions | |
    | version | 10.2.8-MariaDB |
    | version_comment | MariaDB Server |
    | version_compile_machine | x86_64 |
    | version_compile_os | Linux |
    | version_malloc_library | system |
    | version_ssl_library | OpenSSL 1.0.1e-fips 11 Feb 2013 |
    | wsrep_patch_version | wsrep_25.19 |
    +-------------------------+---------------------------------+
    And the value of sql_mode is :
    MariaDB [(none)]> SHOW VARIABLES LIKE "sql_mode";
    +---------------+-------------------------------------------------------------------------------------------+
    | Variable_name | Value |
    +---------------+-------------------------------------------------------------------------------------------+
    | sql_mode | STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
    +---------------+-------------------------------------------------------------------------------------------+

    And when try to install ISP Config display the next error:
    Wrong SQL-mode. You should use NO_ENGINE_SUBSTITUTION. Add

    sql-mode="NO_ENGINE_SUBSTITUTION"

    to the mysqld-section in your mysql-config on this server and restart mysqld aft erwards

    Please advise,
    Regards,
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error message tells you what you shall do and your sql output shows that your current mode is wrong. So why don't you just do what the error message tells you to do?

    your sql-mode: "STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

    the required sql-mode: "NO_ENGINE_SUBSTITUTION"

    so your current SQL mode contains these incompatible settings "STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER" and that's why you have to set the sql-mode line exactly as shown in the error message.
     
  3. Enrique García

    Enrique García New Member HowtoForge Supporter

    Thanks it works.

    But in during installation display:
    PHP Warning: str_replace() expects at least 3 parameters, 2 given in /tmp/ispconfig3-stable-3.1-27129ebba0be40416550abd67bf3333a5207c9e2/install/dist/lib/centos_base.lib.php on line 51

    At the end of the installation:
    Job for amavisd.service failed because the control process exited with error code. See "systemctl status amavisd.service" and "journalctl -xe" for details.

    [[email protected] install]# systemctl status amavisd.service
    ● amavisd.service - Amavisd-new is an interface between MTA and content checkers.
    Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled; vendor preset: disabled)
    Active: failed (Result: start-limit) since Wed 2017-09-20 13:25:01 CDT; 4min 29s ago
    Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 8400 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf (code=exited, status=255)
    Main PID: 3057 (code=exited, status=0/SUCCESS)

    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: amavisd.service: control process exited, code=exited status=255
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: Unit amavisd.service entered failed state.
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: amavisd.service failed.
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: amavisd.service holdoff time over, scheduling restart.
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: start request repeated too quickly for amavisd.service
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: Unit amavisd.service entered failed state.
    Sep 20 13:25:01 www.fyde.com.mx systemd[1]: amavisd.service failed.


    I just purchase the subscription, who is activated??

    Regards,
     

Share This Page