Facebook RSS odd symbol

Discussion in 'HOWTO-Related Questions' started by melat0nin, May 28, 2008.

  1. melat0nin

    melat0nin New Member

    Hi all

    I think there might be a problem in the Facebook RSS feed HOWTO with regard to character encoding.

    In my RSS feed I have pound signs (£), and they appear in facebook as a question mark (?) on top of a black diamond - �

    When I view the RSS feed in Google Reader, the pound sign displays properly - so I'm assuming the problem is not with the data feed itself but with the way Magpie/Facebook API interprets the data.

    Any ideas why this is and how it can be fixed?
    Last edited: May 28, 2008
  2. melat0nin

    melat0nin New Member

    When i run the feed through the feed validator (www.feedvalidator.org) I get this error:

    "Your feed appears to be encoded as "UTF-8", but your server is reporting "US-ASCII""

    which I presume is the root of the problem. The help file here (http://feedvalidator.org/docs/warning/EncodingMismatch.html) suggests there's a problem with the HTTP headers, but it doesn't actually explain where the change should be made.

    Anyone got any ideas?
  3. falko

    falko Super Moderator ISPConfig Developer

    You can try to set
     AddDefaultCharset utf-8
    in your Apache configuration.
  4. melat0nin

    melat0nin New Member


    Many thanks for the suggestion, but it hasn't worked. The RSS feed seems fine though, I can read it in Google reader without any weird symbols, so it's as though the problem is with the intermediary (i.e. MagPie/Facebook) steps.

    Any other thoughts?
  5. falko

    falko Super Moderator ISPConfig Developer

    You could try this in your PHP scripts:
  6. melat0nin

    melat0nin New Member

    Would that be in rss.php or conf.php or what?
  7. falko

    falko Super Moderator ISPConfig Developer

    Put it in conf.php - if I remember right, that file is included in all other PHP files.
  8. melat0nin

    melat0nin New Member

    I'm afraid that doesn't appear to have worked either, and now I'm getting this error at the bottom of my feed on the application page (but not on the profile page):

    Errors while loading page from application
    Parse errors:
    FBML Error (line 26): unknown tag "br..."

Share This Page