External DNS server

Discussion in 'Installation/Configuration' started by NeoSyRenity, Oct 27, 2009.

  1. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    I'm trying to make external DNS server A records to work with site running on ISPConfig 3.

    This configuration should be possible, right?

    But for some reason, I'm getting the server default welcome page, and not the site.

    Any idea how to resolve this?

    Thanks in advance!
     
  2. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    Ok, I partially sorted it out - just needed to define the domain correctly (domain.tld and not www.domain.tld - maybe some check in this page will help future users?).

    The problem is that when I type domain.tld, I reach the site correctly, but when I type www.domain.tld, I reach the server default document directory.

    The server is called exactly same name (www.domain.tld), could it be the reason?
    If yes, anyway to fix it, or I have to change the server name?

    Thanks in advance!
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to use domain.tld in the website settings and if www.domain.tld shall point to the same website then select auto subdomain www in the website settings.
     
  4. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    This is exactly what I have, but on www.domain.tld I'm receiving the server (Debian) "It works!" page, and not the site virtual host.

    Again, my server is named exactly in same way - www.domain.tld. Could it be related?

    Thanks again!
     
  5. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    Any idea about the issue?

    I really need to sort this out soon, otherwise will need to re-install the server with another name - which I really don't want.

    Thanks in advance!
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the content of the apache vhost file of this websites. the file is in /etc/apache2/sites-enabled or a similar directory depending on the linux distribution.
     
  7. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    Here it is:

    Code:
    <Directory /var/www/1trabajo1.com>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost *:80>
          DocumentRoot /var/www/1trabajo1.com/web
    
        ServerName 1trabajo1.com
        ServerAlias [url]www.1trabajo1.com[/url]
        ServerAdmin [email]webmaster@1trabajo1.com[/email]
    
        ErrorLog /var/log/ispconfig/httpd/1trabajo1.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/1trabajo1.com/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client1/web3/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # php as fast-cgi enabled
        <Directory /var/www/1trabajo1.com/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride all
            Order allow,deny
            Allow from all
        </Directory>
    
    
    </VirtualHost>
    
    Thanks.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Do you use www.1trabajo1.com somewhere else in your Apache configuration? What are the outputs of
    Code:
    hostname
    and
    Code:
    hostname -f
    ?
     
  9. NeoSyRenity

    NeoSyRenity New Member

  10. ivomendonca

    ivomendonca Banned

    Yes, thats is the first problem. read how to set an hostname in "perfect server config".
    Hostname is not used for domain resolving so if you add. xpto.anyname.com as hostname ispconfig will work.
     
    Last edited: Oct 29, 2009
  11. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    Thanks for the advice!

    I changed the server name and updated the hosts file, and all works now.

    Should I change anything in ISPConfig as well, or it will pick the name change by itself?

    Regards.
     
    Last edited: Oct 29, 2009
  12. ivomendonca

    ivomendonca Banned

    The name is in the mysql database. just change there i never tried, i think that will work.
    by
     
  13. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    So the only thing I need to update is the field in ISPConfig DB?

    Anything else that should be done?

    Thanks again.
     
  14. ivomendonca

    ivomendonca Banned

    /etc/hosts and database record and maybe will work.
    Backup and try.
     
  15. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    Any idea where are the settings for DB are stored, for ISPConfig 3?

    Regards.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not update anything in the mysql db directly, the settings will not be used then. Just change the settings in the ispconfig interface!
     
  17. NeoSyRenity

    NeoSyRenity New Member

    Hi.

    Thanks - I should have think of this myself! :)

    There are 2 settings, Edit server and Server config (which may be needed to be unified?).

    I presume I should update them both?

    Regards.
     

Share This Page