Experts Please i need help urgent ia m stuck

Discussion in 'Server Operation' started by kadi, Feb 11, 2008.

  1. kadi

    kadi New Member

    hello experts
    I used ghost4linux to copy small hard drive with debian etch 4 to a bigger
    one the g4L .23 has this feature, then after it is finished copying i started
    the server machine from the original (small) hard drive and it doesn't want
    to boot to debian which it starts with Lilo, it says: insert system disk in cdrom, so i try to use the rescue cd for debian, i used as much as i know
    commands and some of it says: files are read only other one says:
    no partion table found, now i can't get to the server and everything is down , i am not expert in linux, this is my first linux server.
    I don't know what to do, it is too much work for me to setup another one
    from the scatch again after all this work.
    Any help will be much appreciated and thanks in advance. :mad:
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you checked all the plugs to make sure that the HDD is properly connected?
     
  3. kadi

    kadi New Member

    Thanks for fast reply

    hello mr/falko
    yes i checked everything after your reply again and still says:
    Disk boot failure insert system disk and press enter.
    I insert debian netinst and select rescue mode but when i select
    install Lilo loader it it goes to (install base system first), and i am afraid
    to do that it may overwrite all my files then i changed
    to shell run debug and it recognize the hda as hdb which is the name
    for the one i was copying to, honestly i am lost i don't know what is going on,
    if even there is a way to copy the all files on the drive i can install debian
    again and copy those files on it.
    I tried again the rescue install from debian 4.0r2 after download it and i got
    something interesting when i choose to install Lilo says:No system files mounted on /target
    so may be the hd is not mounted and how to mount it again i don't know.
    Thanks again very much
     
    Last edited: Feb 11, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    Please use another connector for your HDD so that it gets recognized as /dev/hda.
     
  5. kadi

    kadi New Member

    Thanks again for fast reply

    hello mr/falko
    I changed the cable and the power connector also the hd connection
    on the MB, the same result, what i can see and this is just my view
    is : the system files are corrupted and read only, also the drive is
    Unmounted, alot of these backup software Unmount the drive after
    copying it or hide it , that is why the drive does not work, the computer
    cannot recognize a hidden drive, so this drive even it is recognized in
    the Bios but it is not Mounted.
    I can get to a shell with floppy i have or debian rescue cd but the thing
    is i don't know alot of linux commands specially for situations like this,
    i thought may be i can use the shell to copy hda1 + lilo to another
    place on the drive, or use like mnt/mnt -0 remount hda, i am not
    sure of these commands but the question now is how to correct the
    system files and remount the drive with a shell command.
    BTW i am a visual foxpro former programmer and also A+ certified.
    mr/falko
    i have to add this to the post:
    iI just run the rescue cd and i checked with cmd fdisk -l
    and it says: /dev/hda does not have a valid partition table.
    I just decided to prepair the big HD from a-z again and i installed etc 4.0r2,
    fixing this problem going to take alot of work and may be end with nothing.
    I appreciate your help very much .
    Thanks very much again :)
     
    Last edited: Feb 12, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    You can try to boot Knoppix. It has a GUI, so you can try to mount the broken disk and try to save files from it. Afterwards, I'd try to restore the disk from your Ghost4Linux image.
     
  7. kadi

    kadi New Member

    hello again and thanks for your help

    hello again
    I did put it on a cd version 5.1, then after loading i put
    mount /dev/hda -rw and it says : could not determine
    the filesystem type, and none was specified.
    ineed some commands to see if i can get
    to the files then i can copy it or find a way to move it.
    now what is more important is a question :
    what is the best and simple and safe way to backup the
    new one now? can i back it up making like a bootable dvd ?
    so if this happen again i will just use the media to restore
    it ?
    Thanks very much again:)
     
    Last edited: Feb 13, 2008
  8. chipsafts

    chipsafts New Member

    A VFP programmer? Hooray, another one :)

    There are discussions threads over at http://forums.scotsnewsletter.com/ that deal with similiar problems to yours.

    Does your Knoppix have gparted? If not, create a SysRescue CD (http://www.sysresccd.org) and run gparted and see what it says.

    One problem may be that it does not see the proper disk geometry , maybe your old "disk configuration" file is being seen by the OS
     
  9. kadi

    kadi New Member

    Thanks chipsafts alot for the information

    hello chipsafts
    Thanks alot for the informaion i am going to try it
    but anyway i setup a new server with big HD so
    may be i will just forget about the old one.
    Thanks alot again.
     
    Last edited: Feb 13, 2008
  10. normanp

    normanp New Member

    This has me worried a bit - I think I will practice catastrophic failure before I configure my server much more.

    Would this be sensible?:
    Copy all partitions to new drive (ie as backup) and note partition table details
    Swap drives
    Work out how to get the new drive to boot (ie write partition table etc)
     
  11. kadi

    kadi New Member

    That will be a very good idea

    hello normanp
    this was my first bad experiance with linux, but it
    was my mistake if i did like you said i will not be in
    trouble now, the only thing why i didn't because i
    couldn't find an easy way to do it and even easy
    simple software backup with gui, and this g4L was
    the first one to use because you can start it from
    cdrom but i think i didn't use it right, there are many
    backup programs for linux but most of them command
    line and i am not very advance in linux, so you better
    do it before you get in trouble like me, it cost me alot
    of work i have to setup another one from a-z.
    Thanks:)
     
    Last edited: Feb 13, 2008
  12. normanp

    normanp New Member

    I certainly will! I'm thinking of something similar to Norton Ghost but using the command line. I'll have to also work out the most reliable way to restore an MBR - or at least create one consistent with the partitions. Personally I prefer command line solutions as I got so fed up with trying to remember which tab after clicking what Advanced button etc in M$ Win! Graphical interfaces have a disturbing habit of continually morphing with each new OS release...
     
    Last edited: Feb 13, 2008

Share This Page