Exim4 keeps forwarding emails instead of delivering them

Discussion in 'Server Operation' started by HinterLan, Dec 14, 2011.

  1. HinterLan

    HinterLan New Member

    We've set up an exim4 email server on a Debian6 system. It'll accept emails, and the forwards them upstream to our ISP, even when the emails are for the local system. How do I get it to stop doing this, and deliver the messages to its own mailboxes?
     
  2. nbhadauria

    nbhadauria New Member

    check for following in exim.conf


    domainlist local_domains = @ : localhost : localhost.localdomain
    domainlist virtual_domains = dsearch;/var/spool/mail/conf/virtualdomains
     
  3. HinterLan

    HinterLan New Member

    Here's the conf file generated by dpkg-reconfigure exim4-config.
    I don't see anything for a domainlist.

    dc_eximconfig_configtype='smarthost'
    dc_other_hostnames='mail.network.net,smtp.network.net,network.net'
    dc_local_interfaces='172.16.2.2 ; 172.20.2.2'
    dc_readhost='network.net'
    dc_relay_domains=''
    dc_minimaldns='false'
    dc_relay_nets='172.16.2.2/16;172.20.2.2/16'
    dc_smarthost='smtp.outside.com'
    CFILEMODE='644'
    dc_use_split_config='false'
    dc_hide_mailname='true'
    dc_mailname_in_oh='true'
    dc_localdelivery='maildir_home'


    I'm also wondering if the problem is the MDA instead of the MTA.
     
  4. nbhadauria

    nbhadauria New Member

  5. HinterLan

    HinterLan New Member

    Ran the command as you said and I got this:

    Exim version 4.72 uid=0 gid=0 pid=3498 D=fbb95cfd
    Berkeley DB: Berkeley DB 4.8.30: (April 9, 2010)
    Support for: crypteq iconv() IPv6 PAM Perl Expand_dlfunc GnuTLS move_frozen_messages Content_Scanning DKIM Old_Demime
    Lookups: lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmnz dnsdb dsearch ldap ldapdn ldapm mysql nis nis0 passwd pgsql sqlite
    Authenticators: cram_md5 cyrus_sasl dovecot plaintext spa
    Routers: accept dnslookup ipliteral iplookup manualroute queryprogram redirect
    Transports: appendfile/maildir/mailstore/mbx autoreply lmtp pipe smtp
    Fixed never_users: 0
    Size of off_t: 8
    GnuTLS compile-time version: 2.8.6
    GnuTLS runtime version: 2.8.6
    changed uid/gid: forcing real = effective
    uid=0 gid=0 pid=3498
    auxiliary group list: <none>
    LOG: PANIC DIE
    Exim configuration error in line 19 of /etc/exim4/update-exim4.conf.conf:
    main option "dc_eximconfig_configtype" unknown
    search_tidyup called
    >>>>>>>>>>>>>>>> Exim pid=3498 terminating with rc=1 >>>>>>>>>>>>>>>>

    That doesn't look good.:(
     

Share This Page