Exim4 Debian Etch issues

Discussion in 'Server Operation' started by lordshadow, Apr 24, 2008.

  1. lwh.dk

    lwh.dk New Member

    exim4 heavy

    you can do more with it..


    from the split'd config file of exim4.63
    try enable the clamav once again and add the clamav user to the Debian-exim group in /etc/group

    remember to run update-exim4.conf to make a new running config file.
     
  2. lordshadow

    lordshadow New Member

    Ok this time it seems to have taken without any problems but how can I test that it works or not?
     
  3. lordshadow

    lordshadow New Member

    hmm it looks like my cron jobs have stopped working too! even after restarting cron daemon and exim4

    fetchmail and logrotate have been put into crontabs and logcheck is also part of the process but nothing is getting mailed to me anymore. How can I check whats gone wrong with this?
     
  4. lwh.dk

    lwh.dk New Member

    Testing

    The best way to test is following the mainlog...
    Code:
    tail -f /var/log/exim4/mainlog
    
    If its possible send a eicar vira to your server.

    Im sorry, but i dont know anything about fetchmail....
    I use Exim as a smtp mailgw for other backend mailservers where the user is homed and don't need to fetch mail by a host-provider.

    But when I have troubles with crontab job I always tries to run the command by hand in the shell or make the crontab job pipe it's output to a logfile... and investigate the issue that way.
     
  5. lordshadow

    lordshadow New Member

    /var/log/exim4/mainlog wasn't much help as it displays the output of my fetchmail that I ran manually.

    I tried the link for the virus test file but it came up with page not found??

    Also how can I pipe the output of cron? I don't think that it is even functioning however since fetchmail works when run manually but none of my cron jobs seem to be working.
     
  6. lordshadow

    lordshadow New Member

    Actually it seems that cron is working as my new mail seems to be coming in, however in the past every time cron ran either fetchmail, locgcheck or logrotate it would email me the result through local mail. This process doesn't seem to be working.
     
  7. lordshadow

    lordshadow New Member

    It looks as though my internal mail system isn't working now!

    Even with restarts of exim and cron mail delivery from say user1 to user2 doesn't work. Fetchmail and everything else is up and running though
     
  8. lordshadow

    lordshadow New Member

    I've managed to pinpoint the problem with local mail:

    after running the command:

    Code:
     echo "my test" | mail -s "test message" kayasaman
    
    Exim4's main log file tells me this:

    Code:
    2008-05-04 04:50:45 1JsTNF-00056e-Ax <= [email protected] U=root P=local S=454
    2008-05-04 04:50:56 1JsTNF-00056e-Ax => [email protected] R=smarthost T=remote_smtp_smarthost H=smtp.dsl.pipex.com [62.241.163.100]
    2008-05-04 04:50:56 1JsTNF-00056e-Ax Completed
    
    So I think that local mail is getting sent to my ISP's smtp server?

    What can I do to re-establish localized mail and make sure that it gets sent to the correct user and terminated there?
     
  9. lwh.dk

    lwh.dk New Member

    update-exim4.conf.conf

    what's in your

    Code:
    /etc/exim4/update-exim4.conf.conf
    
     
  10. lordshadow

    lordshadow New Member

    This is my update-exim4.conf.conf file:

    Code:
    # /etc/exim4/update-exim4.conf.conf
    #
    # Edit this file and /etc/mailname by hand and execute update-exim4.conf
    # yourself or use 'dpkg-reconfigure exim4-config'
    #
    # Please note that this is _not_ a dpkg-conffile and that automatic changes
    # to this file might happen. The code handling this will honor your local
    # changes, so this is usually fine, but will break local schemes that mess
    # around with multiple versions of the file.
    #
    # update-exim4.conf uses this file to determine variable values to replace
    # the DEBCONFsomethingDEBCONF strings in the configuration template files.
    #
    # Most settings found in here do have corresponding questions in the
    # Debconf configuration, but not all of them.
    #
    # This is a Debian specific file
    
    dc_eximconfig_configtype='smarthost'
    dc_other_hostnames='localhost'
    dc_local_interfaces=''
    dc_readhost=''
    dc_relay_domains=''
    dc_minimaldns='false'
    dc_relay_nets=''
    dc_smarthost='smtp.dsl.pipex.com'
    CFILEMODE='644'
    dc_use_split_config='false'
    dc_hide_mailname='false'
    dc_mailname_in_oh='true'
    dc_localdelivery='maildir_home'
    
     
  11. lwh.dk

    lwh.dk New Member

    dc_other_hostnames=''

    please look into this part of your update-exim4.conf.conf
    Code:
    dc_other_hostnames=''
    
    I think you need to specify your "local domain name" for howtoforge it would be something like
    Code:
    dc_other_hostnames=' howtoforge.com howtoforge.de ' 
    
    Prehabs it's a idea to backup the current update-exim4.conf.conf and try to run
    Code:
     
    dpkg-reconfigure exim4-config
    
    This "script" generates the update-exim4.conf.conf file
    (This is why I like to make at backup copy of the current one, before running the script again.)
     
  12. lordshadow

    lordshadow New Member

    After adding the lines:

    Code:
    dc_other_hostnames='localhost OptiplexGX110 optiplex-networks.tk'
    
    I again tried the command:

    Code:
    #mail "test" -s kayasaman
    test
    ^D
    
    but I am still not recieving the mail test??

    Two posts ago I gave the location of where the mail is getting sent to (smtp.pipex.com) and I don't understand why the local mail delivery or say internal mail delivery from one user to another isn't working.

    I need to get this back so that cron can update me on certain jobs that it runs.
     
  13. lordshadow

    lordshadow New Member

    Ok I restarted my server and now local mail system seems to be working.

    Now to my original problem; I have a .forward file which filters the output of logcheck to a folder called logcheck, however when it forwards this file it also sends a blank email to the inbox aswell.

    How can I get rid of this blank reciept?

    At the same time how can i check if clam_av and spamassassin are working properly?

    -: which was my original query! :)
     
  14. lordshadow

    lordshadow New Member

    hmm it seems that my local mail delivery system has failed again :-(

    I'm not sure what the cause of it breaking down is. I'm trying to get my domain to resolve so I made a dns server and after I did that it seems like the mail system packed up again.

    Can anyone help at all??
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately I'm no Exim expert... :eek:
     
  16. lordshadow

    lordshadow New Member

    Thanks a lot anyway for everyones help!

    I think it could be something to do with the hostname and domain name of the system?

    I don't think I set DNS and Bind9 up properly to integrate with Exim4. I have another post in the howto section as I am kind of stuck with that too :)

    Kaya
     

Share This Page