Exclude a domain from postfix?

Discussion in 'General' started by dezibel, Sep 3, 2007.

  1. dezibel

    dezibel New Member


    Is there a way to exclude postfix to handle the mail for a domain?

    I currently have two domains on my ispconfig; durum.biz and ifelo.no.

    The mail for durum.biz is now handled by a external mailserver, but i need ifelo.no to be handled localy. mail from outside the server works perfetct, as my mx-records are setup correct, but mail sent internaly, ie from wordpress to a @durum.biz mail, is delivered to the internal durum.biz-mailbox, and not to the external server.

  2. jnsc

    jnsc rotaredoM Moderator

    There is an external mailserver option in ISPConfig. Just enable it for your domain.
  3. dezibel

    dezibel New Member

    but where?

    where's that option?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This option is under options of the website for websites domains like www.domain.com and in the options of every co-domain. I guess in your case, you want to set mailserver to external in the website and the co-domain.
  5. dezibel

    dezibel New Member


    aha! there it is :)

  6. dezibel

    dezibel New Member


    That did not work. I have looked at the configfiles, /etc/postfix/local-host-names, and my domain still shows up there. tired commenting it out, but it get's rewritten by ispconfig. The reason i need this is that my services running on my domain has to sendt some e-mails to my mail-adress, but my mail is hosted by google apps, and not localy on isp-config for this domain. Any clues on what to do?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please see post #4 in this thread. If it still shows up in the file, you did not set it to externam mailserver in the settings of the co-domain.
  8. dezibel

    dezibel New Member

    As allways, you are in total control. Thanks!

    When you said co-domain, my mind read sub-domains first.

Share This Page