Exchange beating Postfix to the punch

Discussion in 'Installation/Configuration' started by dwygant, Sep 17, 2007.

  1. dwygant

    dwygant New Member

    I am attempting to set up Postfix on a virtual machine using VMware in bridged mode. The idea is to scan my incomming mail and then forward it to Exchange for delivery. The vm is running on a Windows Server 2003 Standard. Exchange is running on a Small Business Server located at The vm is using the IP address and is accepting incoming traffic on port 25. I would like the vm to accept port 25 traffic and forward to my exchange server. I have my linksys router set to forward all incoming port 25 traffic to the vm at The problem is that exchange is getting the mail off the network before the vm is and I can not figure out how. Even when I turn off port forwarding on the linksys router the exchange server seems to get the mail. But if I turn off port 25 neither exchange nor postfix answers on port 25 from an outside telnet. When a message is sent it shows up in my outlook inbox and never goes through vm and postfix or my router on port 25. Anyone have any ideas? :confused:
  2. chuckl

    chuckl New Member

    Is the router set up with the SB server on 1.106 as the DMZ host? If so, all 'unknown' traffic will be forwarded there.

    I have seen router/modems that blindly forwarded everything to the DMZ host if one was defined, regardless of the port forwarding settings. i.e. the DMZ host settings preempted the port forwarding settings. I don't say the Linksys is one, but it's a possibility.
  3. flashingcurser

    flashingcurser New Member

    Along with the above...

    For the local network, check your win2k3 dns records. Make sure the local dns records are not pointing MX to the AD domain controller. This, I think, is the default if exchange and dns are on one box. Go to your local forward lookup zone (on the 2k3 box) for your domain and make sure the MX is pointed to your postfix server. It might be wise to delete the current MX record and create a new one. Don't forget to make a PTR record.



    EDIT: I forgot to mention the very first thing you need to do in the windows local forward lookup zone. Make sure your postfix server has an A record and make sure that windows clients can ping it based on fully qualified hostname. Who serves up dns for outside of your network?

    Oh one other thing: does the router have upnp? try turning off all upnp stuff and do strait port forwarding. Also can you telnet to the postfix box from the local network?
    Last edited: Sep 18, 2007
  4. dwygant

    dwygant New Member

    That did it.

    Yes! That did it. I followed your advice regarding the DMZ Host, UPNP and the DNS setup and that did the job. Now postfix on the ubuntu virtual appliance picks up the email and mailscanner begins scanning it immediately. I can watch it live by using the tail -f /var/log/mail.log command.

    Now all I have to do is configure exchange to accept the relay and I'm really cooking with gas! :D

    Thanks so much for your help guys.
    I would have never figured out that upnp thing on my own. :p

    This forum rocks!
  5. syn1234

    syn1234 New Member

    sorry wrong forum
    Last edited: Apr 22, 2009

Share This Page