Evolution can't download mails on remote server

Discussion in 'Server Operation' started by satimis, Apr 22, 2008.

  1. satimis

    satimis New Member

    Hi folks,


    Ubuntu 7.04 server amd64
    Postfix 2.3.8
    Evolution 2.22.1 (running on Archlinux)


    Evolution can't download emails on server but can send mails via server


    Settings:
    Sending Email
    Server Type: SMTP
    Server: smtp.satimis.com
    Type: Plain


    Receiving Email
    Server Type: POP
    Server: pop3.satimis.com
    Authentication Type
    Password


    On clicking Send/Receive, it doesn't popup "Enter Password for Personl" window

    Remark:
    having tried Server: pop.satimis.com
    On clicking "Check for Supported Types" it only hangs there.


    On Sending: clicking "Sent" it popup for Password. After keying in password it sends mails.


    However with same settings only changing "pop3.satimis.com" to "pop.ISP.com

    Evolution can download mails on ISP server


    Please advise where shall I check? TIA


    Remark:


    $ apt-cache policy courier-base
    Code:
    courier-base:
      Installed: 0.53.3-5ubuntu1
      Candidate: 0.53.3-5ubuntu1
      Version table:
     *** 0.53.3-5ubuntu1 0
            500 http://us.archive.ubuntu.com feisty/universe Packages
            100 /var/lib/dpkg/status
    

    $ apt-cache policy courier-imap
    Code:
    courier-imap:
      Installed: 4.1.1.20060828-5ubuntu1
      Candidate: 4.1.1.20060828-5ubuntu1
      Version table:
     *** 4.1.1.20060828-5ubuntu1 0
            500 http://us.archive.ubuntu.com feisty/universe Packages
            100 /var/lib/dpkg/status
    

    $ apt-cache policy courier-maildrop
    Code:
    courier-maildrop:
      Installed: 0.53.3-5ubuntu1
      Candidate: 0.53.3-5ubuntu1
      Version table:
     *** 0.53.3-5ubuntu1 0
            500 http://us.archive.ubuntu.com feisty/universe Packages
            100 /var/lib/dpkg/status
    

    B.R.
    satimis
     
  2. satimis

    satimis New Member

    Cause of problem found

    Hi folks,


    It is the rules of iptables on the remote Mail Server preventing Evolution downloading mails.


    # cat /etc/rc.local
    Code:
    # INPUT
    
    # Set the default policy to drop
    iptables -P INPUT DROP
    
    # Allow existing connections to continue
    iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    
    # Allow the server to talk to itself
    iptables -A INPUT -i lo -j ACCEPT
    
    # allow all VMware MUI HTTP connections in from anywhere
    iptables -A INPUT -p tcp --dport 8222 -j ACCEPT
    
    # allow all VMware MUI HTTPS connections in from anywhere
    iptables -A INPUT -p tcp --dport 8333 -j ACCEPT
    
    # allow all VMware Authorization Daemon connections in from anywhere
    iptables -A INPUT -p tcp --dport 902 -j ACCEPT
    iptables -A INPUT -p tcp --dport 443 -j ACCEPT
    iptables -A INPUT -p tcp --dport 25 -j ACCEPT   # add allowing incoming mails 20080307
    
    # Allow ssh from workstation local IP
    iptables -A INPUT -s 192.168.0.52 -p tcp --dport 22 -j ACCEPT
    iptables -A INPUT -s 192.168.0.2 -p tcp --dport 22 -j ACCEPT
    
    # Allow ssh from workstation public IP
    #iptables -A INPUT -s 220.232.213.178 -p tcp --dport 22 -j ACCEPT
    
    iptables -A INPUT -p icmp --icmp-type echo-request -j ACCEPT
    iptables -A INPUT -j LOG
    
    
    # OUTPUT
    
    # Set the default policy to drop
    iptables -P OUTPUT ACCEPT
    
    # Allow existing connections to continue
    iptables -A OUTPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    
    # Allow the server to talk to itself
    iptables -A OUTPUT -d 127.0.0.1 -j ACCEPT
    
    # Allow DNS requests out
    iptables -A OUTPUT -p udp --dport 53 -j ACCEPT
    iptables -A OUTPUT -p tcp --dport 53 -j ACCEPT
    
    iptables -A OUTPUT -p icmp --icmp-type echo-request -j ACCEPT
    
    
    After stopping iptables running Evolution can download mails on the Mail Server.


    Please advise what rule shall I add to allow Evolution downloading mail.

    Router IP of Archlinux - 192.168.0.52


    TIA


    B.R.
    satimis
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please allow port 110 (POP3) in your firewall.
     
  4. satimis

    satimis New Member

    Solved

    Your advice work. Thanks.


    Steps taken as follows;

    # nano /etc/rc.local

    adding following line under "INPUT"
    Code:
    iptables -A INPUT -p tcp --dport 110 -j ACCEPT
    

    # /etc/init.d/rc.local stop

    # /etc/init.d/rc.local start


    Then Evolution can download mails on this mail serve.


    One thing I can't resolve.

    On Receiving Email --> Server
    I must enter "Public IP"


    "pop.satimis.com" OR "pop3.satimis.com" don't work.


    However on;
    Sending Email --> Server
    "smtp.satimis.com" works w/o problem.


    B.R.
    satimis
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please check if pop.satimis.com and pop3.satimis.com exist and point to the correct server.
    You can check it like this:
    Code:
    dig pop.satimis.com
    dig pop3.satimis.com
     
  6. satimis

    satimis New Member

    $ dig pop.satimis.com
    Code:
    
    ; <<>> DiG 9.3.4 <<>> pop.satimis.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37000
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;pop.satimis.com.               IN      A
    
    ;; ANSWER SECTION:
    pop.satimis.com.        3600    IN      CNAME   mail.satimis.com.
    mail.satimis.com.       3600    IN      A       220.232.213.178
    
    ;; Query time: 210 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Thu Apr 24 23:00:57 2008
    ;; MSG SIZE  rcvd: 68
    
    It points to the Public IP (WAN) of the Mail Server.


    $ dig pop3.satimis.com
    Code:
    
    ; <<>> DiG 9.3.4 <<>> pop3.satimis.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62851
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;pop3.satimis.com.              IN      A
    
    ;; ANSWER SECTION:
    pop3.satimis.com.       0       IN      A       208.67.219.132
    
    ;; Query time: 213 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Thu Apr 24 23:01:11 2008
    ;; MSG SIZE  rcvd: 50
    
    No it points to "208.67.219.132"

    But from the same server
    Code:
    SERVER: 208.67.222.222#53(208.67.222.222)
    

    satimis
     
  7. falko

    falko Super Moderator ISPConfig Developer

    And what's the public IP of your server that works in your email client?
     
  8. satimis

    satimis New Member

    This is a testing. The mail server and the email client box are connected on LAN running the same public IP.


    B.R.
    satimis
     
  9. falko

    falko Super Moderator ISPConfig Developer

    What I wanted to know is if this IP address is the IP address that you see in the dig output for pop3.satimis.com or pop.satimis.com...
     
  10. satimis

    satimis New Member

    pop.satimis.com

    220.232.213.178 is the public IP found on dig pop.satimis.com


    On dig pop3.satimis.com

    I have no idea of the IP 208.67.219.132


    satimis
     
  11. falko

    falko Super Moderator ISPConfig Developer

    And what's your server's IP address? :rolleyes:
     
  12. satimis

    satimis New Member

    LAN 192.168.0.10
    WAN 220.232.213.178 (public IP)
     
  13. falko

    falko Super Moderator ISPConfig Developer

    But pop.satimis.com should work then. Are you absolutely sure it doesn't?
     
  14. satimis

    satimis New Member

    It works. Sorry I made a mistake.


    satimis
     

Share This Page