everything fine - except smtp

Discussion in 'Installation/Configuration' started by isp99, Jun 7, 2006.

  1. isp99

    isp99 New Member

    Hello,

    I went through the directtions for installing Debian 3.1 and the ispconfig. After a few tries I managed to get everything working excepth the sending mail function.

    I have uploaded a site to the web directory and configured the access to Mysql database. Every feature seems to work except smtp.

    DATA:

    netstat -tap

    tcp 0 0 *:imaps *:* LISTEN -
    tcp 0 0 *:pop3s *:* LISTEN -
    tcp 0 0 localhost.localdo:mysql *:* LISTEN -
    tcp 0 0 *:pop3 *:* LISTEN -
    tcp 0 0 *:imap2 *:* LISTEN -
    tcp 0 0 *:www *:* LISTEN -
    tcp 0 0 *:81 *:* LISTEN -
    tcp 0 0 *:ftp *:* LISTEN -
    tcp 0 0 xxxxxxxxxx.co:domain *:* LISTEN -
    tcp 0 0 xxxxxxxxxx.co:domain *:* LISTEN -
    tcp 0 0 localhost.locald:domain *:* LISTEN -
    tcp 0 0 *:ssh *:* LISTEN -
    tcp 0 0 localhost.localdoma:953 *:* LISTEN -
    tcp 0 0 *:smtp *:* LISTEN -
    tcp 0 0 *:https *:* LISTEN -
    tcp 0 0 xxxxxxx.com:ssh dxxxxxxxxxxxx:51378 ESTABLISHED-

    -----------------------------------------------------------------------------------

    ehlo localhost
    250-xxxxxxxxxxx.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME


    -------------------------------------------------------

    A solution would be greatly appreciated!

    Thank you.
     
  2. isp99

    isp99 New Member

    Update condition ISPConfig Debian 3.1

    ISP is providing all services except smtp

    The server is responding and not authentificating smtp users

    :confused:
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    SMTP is running on your server, as you tested yourself wih the telent command.

    Are you in a NAT enviroment behind a router?
    Have you opened the smtp port in your firewall?
    What is the exact error message you get in your email client?
    Is webmail working?
     
  4. isp99

    isp99 New Member

    smtp error for ISPConfig under Debian 3.1

    The server a static ip not using any firewall or router.

    Email client receives messages for imap and pop configuration.

    Email client smtp error message :
    "Trying to log into the SMTP server “xxxxxxxxxxxxx.com” has failed. Please make sure the username and password are correct. If you continue, you may not be able to receive any email."

    http://site/mailuser allows login to alter email settings
    http://site/webmail does not work
     
  5. isp99

    isp99 New Member

    Config Data mail.log ISPConfig Debian 3.1 smtp

    Here are some data from the mail.log file:

    1.Jun 8 18:23:46 server3 postfix/smtpd[7339]:

    connect from xxxxxxxxxxxx.com[xxxxxxxxxxxx]

    setting up TLS connection from xxxxxxxxxxxx.com[xxxxxxxxxxxx]
    TLS connection established from xxxxxxxxxxxx.com[xxxxxxxxxxxx]: TLSv1 with cipher RC4-SHA (128/128 bits)

    warning: SASL authentication failure: Password verification failed

    warning: : SASL PLAIN authentication failed

    lost connection after AUTH from xxxxxxxxxxxx.com[xxxxxxxxxxxx]

    disconnect from xxxxxxxxxxxx.com[xxxxxxxxxxxx]

    2. Jun 8 18:38:09 server3 courierpop3login:

    Connection, ip=[::ffff:xxxxxxxxxxxx]

    LOGIN, user=u5_admin, ip=[::ffff:xxxxxxxxxxxx]

    LOGOUT, user=u5_admin, ip=[::ffff:xxxxxxxxxxxx], top=0, retr=0, time=1

    3. Jun 8 18:24:19 server3 postfix/smtpd[7339]:

    connect from xxxxxxxxxxx.com[xxxxxxxxxxx]

    NOQUEUE: reject: RCPT from xxxxxxxxxxx.com[xxxxxxxxxxx]: 554 <xxxxxxxxxxx@xxxxxxxxxxx>: Relay access denied; from=<admin@xxxxxxxxxxx> to=<xxxxxxxxxxx@xxxxxxxxxxx.COM> proto=ESMTP helo=<[192.168.2.10]>

    disconnect from xxxxxxxxxxx.com

    4. Last Entry in mail.log

    Jun 9 00:20:24 server3 courierpop3login: Connection, ip=[::ffff:xxxxxxxxxxx]

    Jun 9 00:20:25 server3 courierpop3login: LOGIN, user=u5_admin, ip=[::ffff:xxxxxxxxxxx]

    Jun 9 00:20:25 server3 courierpop3login: LOGOUT, user=u5_admin, ip=[::ffff:xxxxxxxxxxx], top=0, retr=0, time=0
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It seems that your SASL is misconfigured.

    Did you follow the DEBIAN 3.1 perfect setup howto closely?

    Please redo the steps for configuring postfix and SASL from the howto.
     
  7. trueshanti

    trueshanti New Member

    Hi there .. i post to this topic since the rest of all according postings to my problem didnt help me out , and because its the newest ..

    :mad: i cannot send from external via authed user

    i get a postfix-error in mail.log

    Code:
    Jun 12 21:52:27 kmxxxxx-xx-01 postfix/smtpd[32047]: connect from localhost[127.0.0.1]
    Jun 12 21:52:28 kmxxxxx-xx-01 postfix/smtpd[32047]: setting up TLS connection from localhost[127.0.0.1]
    Jun 12 21:52:29 kmxxxxx-xx-01 postfix/smtpd[32047]: TLS connection established from localhost[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jun 12 21:52:31 kmxxxxx-xx-01 postfix/smtpd[32047]: warning: SASL authentication failure: Password verification failed
    Jun 12 21:52:31 kmxxxxx-xx-01 postfix/smtpd[32047]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed
    Jun 12 21:52:32 kmxxxxx-xx-01 postfix/smtpd[32047]: lost connection after AUTH from localhost[127.0.0.1]
    Jun 12 21:52:32 kmxxxxx-xx-01 postfix/smtpd[32047]: disconnect from localhost[127.0.0.1]
    :D i have successful results from testsaslauthd for my services ( smtp , imap )

    the setup is done according to "Perfect-Setupup-Debian3.1" and i followed all the other 9 topics about this , but all of the different fixes didnt solve this for me

    my mailclient (kmail) says: that Postfix doesnt support "PLAIN" authetification .. so i guess its a communicationproblem between postfix and saslauthd

    here my config:

    • /etc/postfix/sasl/smtpd.conf:

    Code:
    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    • my default/saslauthd
    Code:
    START="yes"
    PARAMS="-m /var/spool/postfix/var/run/saslauthd "
    MECHANISMS="pam"
    # also tried MECHANISMS="shadow"
    PIDFILE="/var/spool/postfix/var/run/saslauthd/saslauthd.pid"
    PWDIR="/var/spool/postfix/var/run/saslauthd"
    :eek: there is a symlink from /var/run/saslauthd to /var/spool/postfix/var/run/saslauthd

    • telnet to smtp:
    Code:
    ehlo localhost
    250-kmxxxxx-xx.keymachine.de
    250-PIPELINING
    250-SIZE 51200000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    • my postfix_main.cf
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name
    biff = no
    append_dot_mydomain = no
    myhostname = kmxxxxx-xx-01.keymachine.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command =
    smtpd_helo_required = yes
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    allow_percent_hack = no
    message_size_limit = 51200000
    • my postfix_master.cf
    Code:
    smtp      inet  n       -       -       -       -       smtpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       -       300     1       qmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    relay     unix  -       -       -       -       -       smtp
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       n       -       -       lmtp
    anvil     unix  -       -       n       -       1       anvil
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -d -t$nexthop -f$sender $recipient
    scalemail-backend unix  -       n       n       -       2       pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}


    • and generics:


    thanks for help

    -c-:D
     
    Last edited: Jun 12, 2006
  8. falko

    falko Super Moderator ISPConfig Developer

    Code:
    PARAMS="-m /var/spool/postfix/var/run/saslauthd "
    should be

    Code:
    PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
    in /etc/default/saslauthd.
     
  9. trueshanti

    trueshanti New Member

    ok changed the config .. restarted saslauthd and postfix .. same error

    kind regards

    -c-
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Can you redo the Postfix and saslauthd configuration from the tutorial? Please try to follow it as close as possible.
     
  11. trueshanti

    trueshanti New Member

    oh well .. thats what I did :) .. but still the same errors (->PLAIN)
     
  12. falko

    falko Super Moderator ISPConfig Developer

    But you must have done something different from the tutorial, because it's working for me. :)
     

Share This Page