EU DNS configuration

Discussion in 'General' started by mmdollar, Jul 9, 2017.

  1. mmdollar

    mmdollar Member

    Ok so I've installed 2 DNS servers, I want to use one as main and another one as slave. I did the usual fresh install, after that installed bind and then ISPConfig. After that in the interface I configured ns2 to mirror ns1. All is ok domain is working, both are having the zones no error in the logs, but when I scan my domain with some websites I always get error like:
    Code:
    The listed nameservers for domain.com does not all report the same set of nameservers.
    Superfluous name server listed at parent: ns1.domain.com
    Superfluous name server listed at parent: ns2.domain.com
    Is this normal because of the ISPConfig method? Because I checked named.conf.local on both servers are listed as master and non as slave.
     
  2. Stephan Ververda

    Stephan Ververda New Member

    First of all, i am assuming that domain.com is not your real domain and you just replaced your real domain with domain.com in the output in order to hide the real domain name... right?
    So if that is the case the the error (Superfluous name server listed at parent) basically means the following: The authorative name server for the .com domain reports that your domain has 2 nameservers (ns1 and ns2), however your own DNS server contains only one NS record reporting only one name server. Make sure your own zone file has NS records for both nameservers.
     
  3. mmdollar

    mmdollar Member

    Thank you for the answer! It seems that the problem was from namecheap, since I am having a .EU domain there are special rules. This what the support told me:
    Code:
    Just for your note, in order to use private nameservers for your .EU domain name, you should point it to the nameservers in the following format - 1.2.3.4--ns1.yourdomain.eu and 1.2.3.4--ns2.yourdomain.eu
    The thing is that I can only add ns1 with ip--ns1.domain.eu, for the other nameservers it gives me this error when I add them:
    Code:
    Nameserver empty
    Nameserver format invalid
    ISPConfig likes IP's like xxx.xxx.xxx.xxx if it sees IP xxx.xxx.xxx.xx it will give me the error. So my problem is that my IP's are not having 3 numbers at the end (inserted all numbers one by one until I got an error, I've got the error when I entered the last 2 numbers of the IP). Am I getting this right?

    Anyone with ideas? ;/

    Fixed one of the nameservers on DigitalOcean using Floating IP's (it had 3 numbers at the end), trying to figure out to do it on google cloud.
     
    Last edited: Jul 9, 2017
  4. Chris_UK

    Chris_UK New Member HowtoForge Supporter

    By floating ips do you mean that the IP of your server changes (Dynamic) if so this could create an issue for your DNS propogation. If the floating IP is because your server is behind a load balancer then it shouldnt matter as there should be a static ip for the load balancers which is where your glue records should be pointing, the internal "floating" IP's have no need to be directly referenced in your dns.

    Per the subnet requiring 3 digits, have you found a bug thats been introduced? if so you should report that to the developers to look into. Im set up on 3.1.2 and have no such issue, i have servers setup with both 2 and 3 digit subnet ip's.
     
  5. mmdollar

    mmdollar Member

    Yes you are right about floating IP's not working correctly with DNS, I solved the issue with deleting the droplet and starting again until it gives me a address (normal one) which ISPConfig likes. I will report it tomorrow, when I get back home and try to give them example IP's.
     
  6. yodaofborg

    yodaofborg New Member

    Just FYI, not that this is a problem now, but if you have the IP 192.168.1.22 and need xxx.xxx.xxx.xxx you can use 192.168.001.022 (its the same thing)
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess there is no problem at all, this tread mixes up the DNS transfer meta format for DNS names with the actual name server name and setup in ISPConfig. What he received an error for is not the IP address, you can verify that easily by entering an IPv4 address with just one or 2 digits at the end, you won't get an error. He received an error because he entered the META hostname '1.2.3.4--ns1.yourdomain.eu' used by the registry instead of the actual dns server hostname 'ns1.yourdomain.eu'. The format '1.2.3.4--ns1.yourdomain.eu' is used at the namecheap domain robot and that's why the namecheap support told you to use it there but this is not to be used on your own nameserver.

    This refers to the registry information for .eu domains and not the dns nameserver information that has to be entered in ISPConfig. So when you want to tell the .eu registry that you use a custom nameserver, then you use this format "1.2.3.4--ns1.yourdomain.eu" at the company where you register your domain but NOT in the BIND zone (and therefore not in ISPConfig). In BIND, you would just use 'ns1.yourdomain.eu' as DNS server name.
     

Share This Page