Etch vs Lenny Install (falko tutorials)

Discussion in 'Installation/Configuration' started by Done_Fishin, Oct 10, 2009.

  1. Done_Fishin

    Done_Fishin New Member

    Back at the beginning of August my daughter told me that she was starting her "practical" working for a company that uses a Debian Etch server, and she (nor I) have any hands-on experience working with Linux servers. She's been given a few projects using Joomla to help update the site (from what I gather) only to find that she was experiencing problems handling the linux side of it. I have a very small amount of experience with knoppix, ubuntu, fedora and a few others so I am not scared about getting my feet wet on yet one more distro. I said I would build a Debian server for her, so that she could dig and discover :D It also gives me the motivation to dig & discover too!:rolleyes:

    I have some old PC's that are ideal for the purpose and around beginning August started to follow the The Perfect Setup - Debian Etch (Debian 4.0) tutorial not getting much farther than Page 3 until I found a vi cheat sheet .. apart from lack of time, forgetting the passwords used, not understanding what was to be done etc and getting myself out of trouble, I also had visitors that kept me away from my project from 15th Sept until 4th October.
    Whilst I was getting ahead though I must have re-installed the basic system some 20 times. I also tried to make files on my CD2USB Ubuntu HDD installation which I used to copy said files over to the Debian installed HDD. All good fun and a great learning experience for a noob like me .

    to get to the point though .. by the time I returned to my project on 5th October I had managed to get the vi cheat sheet and proceeded a bit farther into the installation and arriving at a point where to the point where I had proceeded to
    vi /etc/default/syslogd
    only I just couldn't find the file to edit !!

    it was after several repeat installs that I realised that I was no longer installing ETCH but in fact LENNY!!

    On another forum I am member of, one of the linux guys pointed me at the
    The Perfect Server - Debian Lenny (Debian 5.0) tutorial and I downloaded the latest 5.03 Netinst CD then followed instructions.

    Only point is that things haven't gone quite the same way as they had earlier although I don't know if I am to blame for that by jumping a step and then going back over my tracks !!

    This part of installing ETCH was working well but the same "equivalent" part for LENNY seems to bring an error finding the hostname .

    The above works ..

    This bit below doesn't !! ( I am using and by accident I missed the apt-get install ssh openssh-server step and installed it after this failed first time.. running the loop again didn't seem to help at all ..


    What I get at this pooint is this

    hostname -f 
    [B]hostname: hostname look up failure[/B]
    when I first got the error I checked that I had given all the correct commands in vi & CLI .. no typos and no accidents. I realised that I had forgotten to install openssh-server, installed it, tried hostname -f again, re-ran all the instructions again but each time came back to the same error .. and now I am wondering .. do I start over again ( no problem , the more the better, I'll become an expert :cool:) or is there something that shoukld have been mentioned but wasn't !!

    your help and expertise will be gratefully appreciated

    I have tried the missing "reboot" instruction but that didn't help either
  2. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    cat /etc/hosts
  3. Done_Fishin

    Done_Fishin New Member

    cat /etc/hosts

    My sincerest apologies .. I had made a typo, missing out the "f" in webfreak!
    I have repaired the damage and it's working now ..

    Thanks for helping me to see the light .. and sorry for wasting your time. I should have seen that last night
  4. Done_Fishin

    Done_Fishin New Member

    when rebooting the my last attempted installation, it seems that something had gone wrong with the system booting very slowly, I would say that it looked as though it may have crashed too and was trying to make some sort of recovery .. I then hit the power off button as it was trying to boot the kernel and "not getting anywhere fast".

    I decided to make yet another installation, making sure this time that I followed instructions to the letter and didn't make the same mistake like last time (caused within vi I had unwittingingly gone into overwrite mode and not seen my typo).

    However at around the same point where I had problems following the Etch instructions I now have a similar problem following the Lenny Instructions.

    When issuing the command
    vi /etc/rsyslog.d/bind-chroot.conf
    I find I am creating a new file !!


    dir /etc/rsyslog.d/bind-chroot.conf
    I am getting a response

    dir: cannot access  /etc/rsyslog.d/bind-chroot.conf: no such file or directory

    dir /etc/rsyslog.d/
    brings no error message so I assume that the directory exists.

    My question is whether we are opening a new file at this point or have I made another error somewhere?

    I have noticed that your instructions are probably aimed at those who know what they are doing or manage to guess what they must do, due to prior experience. I also had an error message when installing quota and running "quotacheck -avugm" however I took this to be because it was the first time being run, a second run brought me no error messages. This is not a criticism so please do not take it as one .. I have been in the electronics business (repairs, production and commissioning) for 40 years and I know only too well how easy it is to assume that the reader either "knows" or "has been down this road before" then gets confused when things don't go the way expected (Murphys Law in action):D

    By the way, Thanks for the great tutorial, without it I would never even have gotten this far
  5. falko

    falko Super Moderator ISPConfig Developer

    No, the file should already exist on your system. Are you sure you followed all instructions?
  6. Done_Fishin

    Done_Fishin New Member

    as far as I can tell , yes .. I went back through each step on CLI and verified that all was OK, no typo's and nothing missing .. I added the file thinking I might have to create from new then progressed .. I now get

    postconf: fatal: missing '=' 
    when I try to write

    postconf -e 'smtpd sasl_local_domain ='
    Should I just start over .. (no problem .. the more I do it the easier it becomes :D and the more I get used to using "vi")
  7. Done_Fishin

    Done_Fishin New Member

    I shall start over .. I see that there are a lot of problems associated with "missing '=' " from searches I hqav done on the net. Also I note from the postfix manual that "postconf -e" only has two entries, neither of which seems to help me ..
  8. Done_Fishin

    Done_Fishin New Member

    It happened again

    it would appear at this stage that /etc/rsyslog.d/ is an empty folder.

    ls /etc/rsylog.d display no content , neither does ls -a /etc/rsyslog.d/

    I have followed the instructions carefully only to come back with the same error as before .. it wants to create a new file /etc/rsyslog.d/bind-chroot.conf

    I had a quick search around but couldn't find a file with that name anywhere.

    Am I doing something wrong ??

Share This Page