/etc/shadow Mirror Server ?

Discussion in 'Installation/Configuration' started by Rapid2214, Aug 19, 2010.

  1. Rapid2214

    Rapid2214 New Member

    Hi,
    I have 2 servers in an ISPConfig Mirror, on the 2nd server the user isn't being created for the website (web35), although its being created on the primary server.

    Any ideas why?

    Web/FTP/Mail settings are transferring fine...


    Thanks,

    Marty
     
    Last edited: Aug 21, 2010
  2. Rapid2214

    Rapid2214 New Member

    Bump ;)

    Marty
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    If you setup the system as mirror, then the shall user should be created on boths servers automatically. If thats not the case on your system, enable debugging for the slave server in ispconfig, create a new website and check if the shell user gets created or if there are any errors in the debug output.
     
  4. Rapid2214

    Rapid2214 New Member

    I thought that is what should happen, how do you enabled debugging?

    Thanks

    Marty
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    System > Server config > Server (name of the server) > Server > Loglevel
     
  6. Rapid2214

    Rapid2214 New Member

    Ok, Debug shows it has added a user:
    Code:
    2010-08-21 20:34  	MOSS  	Debug  	Adding the user: web36
    But these are the last lines in my /etc/shadow
    Code:
    web24:!:14819:0:99999:7:::
    web25:!:14819:0:99999:7:::
    web26:!:14819:0:99999:7:::
    web27:!:14819:0:99999:7:::
    web32:!:14821:0:99999:7:::
    
    :S Help Please

    Marty
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    And you are sure that you enabled debugging for the slave and not the master? Then check the group and password files on the slave with the commands:

    pwck

    and

    grpck

    to ensure that they are not corrupted.
     
  8. Rapid2214

    Rapid2214 New Member

    No, MOSS is the slave of ROY.

    Code:
    [email protected]:~# pwck
    user 'lp': directory '/var/spool/lpd' does not exist
    user 'news': directory '/var/spool/news' does not exist
    user 'uucp': directory '/var/spool/uucp' does not exist
    user 'list': directory '/var/list' does not exist
    user 'irc': directory '/var/run/ircd' does not exist
    user 'gnats': directory '/var/lib/gnats' does not exist
    user 'nobody': directory '/nonexistent' does not exist
    user 'syslog': directory '/home/syslog' does not exist
    user 'ntp': directory '/home/ntp' does not exist
    user 'haproxy': directory '/home/haproxy' does not exist
    pwck: no changes
    [email protected]:~# grpck
    duplicate group entry
    delete line 'sshusers:x:5002:'? y
    'web24' is a member of the 'sshusers' group in /etc/group but not in /etc/gshadow
    'web25' is a member of the 'sshusers' group in /etc/group but not in /etc/gshadow
    'web26' is a member of the 'sshusers' group in /etc/group but not in /etc/gshadow
    'web27' is a member of the 'sshusers' group in /etc/group but not in /etc/gshadow
    'web32' is a member of the 'sshusers' group in /etc/group but not in /etc/gshadow
    'www-data' is a member of the 'client8' group in /etc/group but not in /etc/gshadow
    grpck: the files have been updated
    
    

    Marty
     
    Last edited: Aug 22, 2010
  9. Rapid2214

    Rapid2214 New Member

    Ok,
    It seems like after those commands, it all started working again,
    Adding clients then websites work.
    Adding websites for old clients work. :)

    What do those commands do?

    Thanks for your help,

    Marty
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    They do a consistency check of the passwd, shadow and group files.
     
  11. Rapid2214

    Rapid2214 New Member

    Ok, Thanks for your help!
     

Share This Page