/etc/postfix/local-host-names again

Discussion in 'Installation/Configuration' started by Br8knitOFF, Mar 27, 2010.

  1. Br8knitOFF

    Br8knitOFF New Member

    Been looking around for a solution for my problem and have seen a lot of suggestions and similar problems, but nothing appears to be a fix.

    Brand new ISPConfig system (2.2.35) running on debian lenny. Followed Falko's perfect config to a tee.

    The problem is that somewhere/for some reason, ispconfig insists on appending the 'www' to the hostname I've got configured for a couple of domains we're accepting mail for.

    When it does that, it rejects mail for local recipients because '[email protected]' isn't in the recipients table...(because ispconfig is rewriting the /etc/postfix/local-host-names for the target domain as 'www.example.com'.

    I've got no subdomains for either domain configured on this box, and it's not obeying a manual entry at the bottom of the local-host-names file.

    Right now, my workaround is to delete the www field in the basis tab of the domain, go into the DNS zone inside iSPConfig and delete the 'www' host from the domain, and it will rewrite the local-host-names file correctly. (example.com)

    However, upon restart of ISPConfig or reboot of the server, the problem is back and rewrites the domain as 'www.example.com' and rejects mail for '[email protected]'.

    A bonus is the server is in production now, and we're only using it for hosting mail- no webs/databases.

    Thanks in advance!
  2. falko

    falko Super Moderator ISPConfig Developer

    Please create a Co-Domain example.com (without www).
  3. Br8knitOFF

    Br8knitOFF New Member

    As usual, you came through BIG time- thank you so much!

    I ran into this problem once before a LONG time ago, but couldn't for the life of me remember what the fix was.

    Popped into another of my ISPConfig boxes and sure enough, that's what I did. (probably at your suggestion)

    Thanks again!!!
  4. anomaly0617

    anomaly0617 New Member


    I too have followed one of your wonderful how-to documents to create a LAMP server on a CentOS 5.x server running ISPConfig. For those, I thank you!

    I'm also running into the same problem as the gentleman above, but I cannot figure out what you mean by "create a co-domain" - can you clarify where I find this setting? I assume it's somewhere in the admin interface for ISPConfig3?

    Thank you!
  5. falko

    falko Super Moderator ISPConfig Developer

    This thread is about ISPConfig 2. Please post in the ISPConfig 3 forum.

Share This Page