/etc/aliases only working when mail sent locally

Discussion in 'Server Operation' started by sj200449, Oct 9, 2011.

  1. sj200449

    sj200449 New Member

    Not sure on this one, I know /etc/aliases is meant to be local delivery accounts but I am getting

    Recipient address rejected: User unknown in virtual mailbox table;

    for the root and postmaster emails when I send to them from outside my network.

    postmaster: root
    root: [email protected]


    ...postconf -n :
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    content_filter = amavis:[127.0.0.1]:10024
    daemon_directory = /usr/libexec/postfix
    data_directory = /var/lib/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = all
    inet_protocols = all
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = mail.fluffyrodent.co.uk, localhost, localhost.localdomain
    myhostname = mail.fluffyrodent.co.uk
    mynetworks = 127.0.0.0/8
    newaliases_path = /usr/bin/newaliases.postfix
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
    receive_override_options = no_address_mappings
    relayhost = smtp.blueyonder.co.uk
    sample_directory = /usr/share/doc/postfix-2.6.6/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    unknown_local_recipient_reject_code = 550
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_gid_maps = static:5000
    virtual_mailbox_base = /home/vmail
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_maildir_extended = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    virtual_uid_maps = static:5000

    Do I have to set up forwardings? I dont think I did previously.

    Regards,
    Stephen.

    P.S.
    I noticed in Section 5 Apply Quota Patch To Postfix of

    http://www.howtoforge.com/virtual-u...rier-mysql-and-squirrelmail-centos-6.0-x86_64

    Add Patch0: postfix-vda-v10-2.8.2.patch to the # Patches stanza, and %patch0 -p1 -b .vda-v10 to the %setup -q stanza

    the version numbers of the portions to add do not agree with the previously downloaded ones.
     
  2. sj200449

    sj200449 New Member

  3. sj200449

    sj200449 New Member

    [SOLVED] /etc/aliases only working when mail sent locally

    Im presuming yes as placing the desired info in the Forwardings table works - local server mail already worked.
     

Share This Page