errors with mysql_secure_installation

Discussion in 'Installation/Configuration' started by momfer, Oct 15, 2009.

  1. momfer

    momfer New Member HowtoForge Supporter

    Hi!

    I am working on an ISPconfig install on openSuSE 11.1 and got errors when using the mysql_secure_installation:

    #> mysql_secure_installation

    set root password >YES

    new password: **********
    re-enter new password:**********

    reloading privilege tables >> ...success!

    remove anonymous users > YES
    ERROR 1045 (28000): Access denied for user 'root'@'localhost'(using password: YES)
    ... Failed!


    I am using virtual server using snapshots, so I tried it several times. Always the same error.

    What to do?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you set a MySQL password before, or is this an unprotected installation (i.e., no password)?
     
  3. momfer

    momfer New Member HowtoForge Supporter

    Hi Falko,

    Thanks for the reply.

    Before running mysql_secure_installation, there was NO password added to MySQL. I just followed the "PerfectServer -opensuse 11.1 ISPConfig 3" how-to up to page 4, where I got stuck with the mysql_secure_installation issue.

    Hope you (or someone else) can help with this issue.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Hm... Does your MySQL password contain any special characters? Maybe the mysql_secure_installation command can't cope with them.
     
  5. momfer

    momfer New Member HowtoForge Supporter

    Thanks for that, Falko.

    Password contains special characters.

    Will try password without any special chars and report results in this topic later.
     
    Last edited: Oct 17, 2009

Share This Page