Errors occurred when selecting "manageement"tab

Discussion in 'Installation/Configuration' started by kingofswing, Apr 29, 2007.

  1. kingofswing

    kingofswing New Member

    I've installed ispconfig on a centos 4.4 server several months ago, at first no problem in using "Management " ,recently I re-enter the ispconfig with admin,
    but found that when selecting "Management", the right tree did not work, then google the keywords found the same problem :
    http://www.howtoforge.com/forums/archive/index.php/t-569.html
    on the bottom of this thread a guy nicknamed "cpcpy" , he said no problem when using firefox, so I dl the firefox, it works under firefox, anyone can help ? TIA
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which browser do you use to access the tree menu that did not work for you?
     
  3. kingofswing

    kingofswing New Member

    HI,till :
    thank you for your attention, I use IE 6.0 , as I said in my post , I downloaded firefox 2.0 & found that "Management Tab" can work under Firefox, all that before (I mean before I found the problem using IE) I had changed the mysql root's password to a new one, and found all went wrong opening http://mysite.com:81, lots of errors ! so I changed MySQL root's back to its old one, then can reopen the main admin page, but I didn't notice if Management tab is Ok using IE, so I google to find a thread which has the same problem as mine, becoz I don't want to reinstall ISPconfig ,so I download a Firefox ,and try to access the admin page of ispconfig, As you can see,Firefox can open the management tab normaly! I didn't changed anything but modified the MySQL's root password.
    Hope you guys understand what I typed,my home language is Chinese. :)

    Recently I found another problem regarding changing a DNS record using ISPconfig's DNS tab, for example, if I create a dns record previously, and now We want to changed the dns name to another , click save, but have no effect in Vhost.conf, the old dns vhost is still there.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure why this happens... :(

    What exactly did you do? Change an IP address?
     
  5. kingofswing

    kingofswing New Member

    maybe what I explained confuses all of you, the problem occurs when changing an existing DNS A record using the DNS management tab, for example, step 1: create a new A record "abcdefg.mydomain.com", then,step 2: change "abcdefg" to a short one "abc", ISPconfig do save that change, but it doesn't change the virtual host settings in the included Vhost_config file.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up DNS and webserver. Dns Records are stored in the DNS Server (BIND) and not the webserver (apache). So changing a DNS-A Record never changes the webserver configuration file (Vhost_ispconfig.conf).

    If you want to change the webserver, you must edit the co-domain or hostname of the website and not a A-Record in the DNS-Manager.
     

Share This Page