errors mail

Discussion in 'Tips/Tricks/Mods' started by danmax, Nov 4, 2008.

  1. danmax

    danmax New Member

    I installed ispconfig on CentOS 5.2 and can not receive mail from yahoo mail the mail back ( not find the address)
    thanks a lot
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log or in the bounce mail?
     
  3. danmax

    danmax New Member

    when they send mail from yahoo receive the following message

    Sorry, we were unable to deliver your message to the following address.

    <[email protected]>:
    No MX or A records for maxitell.ro

    --- Below this line is a copy of the message.

    Received: from [76.13.13.25] by n6.bullet.mail.ac4.yahoo.com with NNFMP; 06 Nov 2008 06:15:00 -0000
    Received: from [76.13.10.163] by t4.bullet.mail.ac4.yahoo.com with NNFMP; 06 Nov 2008 06:15:00 -0000
    Received: from [127.0.0.1] by omp104.mail.ac4.yahoo.com with NNFMP; 06 Nov 2008 06:15:00 -0000
    X-Yahoo-Newman-Property: ymail-3
    X-Yahoo-Newman-Id: [email protected]
    Received: (qmail 41214 invoked by uid 60001); 6 Nov 2008 06:15:00 -0000
    DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws;
    s=s1024; d=yahoo.com;
    h=X-YMail-OSG:Received:X-Mailer:Date:From:Reply-To:Subject:To:MIME-Version:Content-Type:Message-ID;
    b=QY9zR8r76GrVrnBKqcxsIoU6ruupmODuBB8PgTXvoUJloPJj/9YErfDxlTxmZQMbIV3PhCgNJTGUv4nwqJPyBw0JQ1EYAQndE/XjNXmQLLblugxoyZMD67LNNwtSyc9AtoVPiJia8pOuXlUVpsigPSUE/mc4pJlCNiAdjKOGJ5A=;
    X-YMail-OSG: OMf6qaUVM1kgxCtVdhEGg5Jgg3_gs.k0vDG6L6nDlSWl3W0vuYURIRxmkDcbUF6fmFMQgHZnxotlcqyoUa.gQ2nfksRoG7UlQH.KkmLis2stEb_XiYKpZapupkSZYaxmqmQQi.VIYzE8QjUnH3LB9dKlJjbf
    Received: from [83.103.197.208] by web59409.mail.ac4.yahoo.com via HTTP; Wed, 05 Nov 2008 22:15:00 PST
    X-Mailer: YahooMailWebService/0.7.260.1
    Date: Wed, 5 Nov 2008 22:15:00 -0800 (PST)
    From: Maxim Dan <[email protected]>
    Reply-To: [email protected]
    Subject: test
    To: [email protected]
    MIME-Version: 1.0
    Content-Type: multipart/alternative; boundary="0-1052393409-1225952100=:39704"
    Message-ID: <[email protected]>

    --0-1052393409-1225952100=:39704
    Content-Type: text/plain; charset=us-ascii
     
  4. danmax

    danmax New Member

    I tested with DNSGoodies

    EMAIL RESULT

    Invalid AWS Request!

    Invalid AWS Request!

    Invalid AWS Request!

    Invalid AWS Request!

    Invalid AWS Request!

    maxitell.ro
    Title
    Server Type Apache/2.2.3 (CentOS)

    Invalid AWS Request!

    Invalid AWS Request!

    Invalid AWS Request!

    Invalid AWS Request!

    Invalid AWS Request!

    SSL Certificate
    Valid? ERROR
    Created 2008-11-02 16:13:51 GMT
    Expires 2009-11-02 16:13:51 GMT
    Issued To SomeOrganization
    SomeCity, --
    Issued By [email protected]
    SomeCity
     
  5. danmax

    danmax New Member

    Openrelay Check:

    Test your mail server for Open Relay:

    >> MAIL FROM:<[email protected]>
    << 501 5.1.7 Bad sender address syntax
    >> RCPT TO:[email protected]
    << 503 5.5.1 Error: need MAIL command
    >> RSET
    << 250 2.0.0 Ok


    DNS Query Lookup
    (A, MX, NS, SOA, PTR)

    Enter Hostname or IP:


    A 83.103.197.208
    MX 10 server1.maxitell.ro.
    CNAME No CNAME record found.
    NS server1.maxitell.ro.
    PTR No PTR record found.
    SOA server1.maxitell.ro. admin.maxitell.ro
    2008110502 28800 7200 604800 86400

    :)
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please create an A record for server1.maxitell.ro:

    Code:
    mh1:~# dig server1.maxitell.ro
    
    ; <<>> DiG 9.3.4 <<>> server1.maxitell.ro
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 45191
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.maxitell.ro.           IN      A
    
    ;; AUTHORITY SECTION:
    maxitell.ro.            10800   IN      SOA     server1.maxitell.ro. admin.maxitell.ro. 2008110601 28800 7200 604800 86400
    
    ;; Query time: 65 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Fri Nov  7 12:44:24 2008
    ;; MSG SIZE  rcvd: 79
    
    mh1:~#
     
  7. danmax

    danmax New Member

    [[email protected] ~]# dig server1.maxitell.ro

    ; <<>> DiG 9.3.4-P1 <<>> server1.maxitell.ro
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 49032
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;server1.maxitell.ro. IN A

    ;; AUTHORITY SECTION:
    maxitell.ro. 10800 IN SOA server1.maxitell.ro. admin.maxitell.ro. 2008111402 28800 7200 604800 86400

    ;; Query time: 1079 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Fri Nov 14 22:51:50 2008
    ;; MSG SIZE rcvd: 79
     
  8. falko

    falko Super Moderator ISPConfig Developer

    There's still no A record for server1.maxitell.ro... If tere was one, you'd see an ANSWER section.
     
  9. danmax

    danmax New Member

    is in
    A Record
    IP-Adress 83.103.197.208
    hostname www

    MX Record
    Mailserver server1.maxitell.ro
    Hostname www
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    As falko ponted out, you need an a-record for server1 and not for www. So, create a record:

    A Record
    IP-Adress 83.103.197.208
    hostname server1

    and the MX record has to be:

    MX Record
    Mailserver server1.maxitell.ro
    Hostname
     
  11. danmax

    danmax New Member

    it's ok
    thanks Falko
     
  12. danmax

    danmax New Member

    sorry,
    but now i can not send the email
     
  13. danmax

    danmax New Member

    I'm looking at var/log/maillog
     
  14. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when you try to send an email?
     
  15. danmax

    danmax New Member

    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '[email protected]'. Subject 'Re: solutii interconectare fibra optica', Account: 'office', Server: 'server1.maxitell.ro', Protocol: SMTP, Server Response: '554 5.7.1 <[email protected]>: Relay access denied', Port: 25, Secure(SSL): Yes, Server Error: 554, Error Number: 0x800CCC79
     
  16. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/main.cf? Did you enable "Server requires authentication" in your email client?
     
  17. danmax

    danmax New Member

    yes i i enable 'Server requires authentification' in my email client

    i think it's a problems with email client, because with uebimiau sends the mail

    in etc/postfix/main.cf
    =======================================================

    # SENDING MAIL
    #
    # The myorigin parameter specifies the domain that locally-posted
    # mail appears to come from. The default is to append $myhostname,
    # which is fine for small sites. If you run a domain with multiple
    # machines, you should (1) change this to $mydomain and (2) set up
    # a domain-wide alias database that aliases each user to
    # [email protected]host.
    #
    # For the sake of consistency between sender and recipient addresses,
    # myorigin also specifies the default domain name that is appended
    # to recipient addresses that have no @domain part.
    #
    #myorigin = $myhostname
    #myorigin = $mydomain
    [...]
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    myhostname = server1.maxitell.ro
    home_mailbox = Maildir/
    mailbox_command =

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
  18. falko

    falko Super Moderator ISPConfig Developer

    This sounds as if "Server requires authentication" is not enabled. Please double-check.
     
  19. danmax

    danmax New Member

    it's ok now

    thanks Falko
     

Share This Page