Errors installing ClamAV

Discussion in 'Installation/Configuration' started by msp, Mar 31, 2013.

  1. msp

    msp Member

    Hi all

    I'm running through The Perfect Server Debian Squeeze (Bind/Dovecot/Nginx/ISPConfig3)

    On this page when I run

    Code:
    apt-get install amavisd-new spamassassin clamav clamav-daemon zoo unzip bzip2 arj nomarch lzop cabextract apt-listchanges libnet-ldap-perl libauthen-sasl-perl clamav-docs daemon libio-string-perl libio-socket-ssl-perl libnet-ident-perl zip libnet-dns-perl
    The output shows

    Code:
    Clamav signatures not found in /var/lib/clamav ... failed!
    Please retrieve them using freshclam ... failed!
    Then run '/etc/init.d/clamav-daemon start' ... failed!
    
    I had some problems around ClamAV in my last installation of ISPConfig and I think they caused its eventual downfall. So I want to ensure I'm following-up on every error message I see during a clean install!

    I'm guessing the above is not okay?

    Please help!
     
    Last edited: Mar 31, 2013
  2. darinpeterson

    darinpeterson HowtoForge Supporter

    It happens every time, yes. After that sequence during the install, do:

    Code:
    freshclam
    
    Once the downloads are complete, do:

    Code:
    /etc/init.d/clamav-daemon start
    
    Even if you haven't done it yet, just run freshclam and you can restart your clamav service.

    Darin
     
  3. msp

    msp Member

    Darin,

    Worked perfectly.

    Super, thanks.

    Regards,

    Mat
     
  4. darinpeterson

    darinpeterson HowtoForge Supporter

    Great! You're welcome...
     

Share This Page