Error when trying to access records in DNS with IDN, as client.

Discussion in 'Installation/Configuration' started by elmacus, Jun 11, 2015.

  1. elmacus

    elmacus Member HowtoForge Supporter

    ERROR
    1. The Zone (soa) can not be changed. Please ask your Administrator if you want to change the Zone name
    This happens when logging in as client on a IDN domain, and try to access Records in DNS settings.
    php5-intl is installed so the domain is showed as IDN but cant save that since it is not allowed.
    If i replace the IDN with the punycode it works and can switch to record form and can change records. Clients dont understand this ofc.
    As admin it works as expected, no error.
    Version 3.0.5.4p6 and all patches installed.
    Is this a bug or something wrong with my system ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Neither nor. When a dns zone has been added by the admin (and not by the client himself or by the admin using the login as client function) then this zone is protected from changes. This measn that the clinet is allowed to add records, but he is not allowed to change the zone itself.
     
  3. elmacus

    elmacus Member HowtoForge Supporter

    But client cant add or see any records at all. You missunderstand the problem sligthly.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ahh ok, I see now. Thats strange indeed, I'll add it to the bugtracker.
     
    elmacus likes this.
  5. elmacus

    elmacus Member HowtoForge Supporter

    Still not fixed for 3.1 stable.
    The error exists also for email and websites.
    If you uinstall php5-intl then it works as expected, since the punycode is then in the domain texbox instead of the åäöÅÄÖØ.
    https://git.ispconfig.org/ispconfig/ispconfig3/issues/3594
    The fix is the check if domainname is still the same after IDN conversion, so client can update himself.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Works fine in 3.1 just added a test tld. See screenshots. Thank you for pointing out that we missed to close the bug hich has already been fixed months ago.
     

    Attached Files:

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Btw, in emails and websites it works flawlessly as well. I have several idn domains on my live servers too and I'am able to edit them as client without problems. Here a screenshot of a website domain with german umlauts.
     

    Attached Files:

  8. elmacus

    elmacus Member HowtoForge Supporter

    SOLVED
    Update: it does work correct in DNS, email and website.
    The DNS-server was not assigned in the limit-template on the testserver. Therefore it looked as same bug.
    Thanks for all help.
     
    Last edited: Oct 13, 2016
    Jesse Norell likes this.

Share This Page