Error when tried access to the panel in a new server

Discussion in 'Installation/Configuration' started by andresgt2000, Sep 1, 2017.

  1. andresgt2000

    andresgt2000 Member

    Hi I followed this full tutorial for:

    The Perfect Server - Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1

    When tried acces to the panel I get this error: 500 Internal Server Error.

    When I see the error log from apache I get this warning and error:

    [Tue Aug 22 12:19:46.013840 2017] [fcgid:warn] [pid 5068] (104)Connection reset by peer: [client 192.0.1.26:41388] mod_fcgid: error reading data from FastCGI server

    [Tue Aug 22 12:19:46.014001 2017] [core:error] [pid 5068] [client 192.0.1.26:41388] End of script output before headers: index.phpI tried find a solution in the comments and in the forum but I not get a solution yet. Some one have got this error too?

    Note: I don't enable access https for the panel.

    Server Version Ubuntu 16.04.3 LTS (GNU/Linux 4.4.0-93-generic x86_64)
     

    Attached Files:

  2. Jesse Norell

    Jesse Norell Well-Known Member

    check the perfect server guide and make sure you installed all the required packages, then try downloading ispconfig source, running update.php and let it reconfigure services.
     
  3. andresgt2000

    andresgt2000 Member

    Hi Jesse

    I verify the requirements and dowload the last ispconfig installer, and execute the update but not work.

    I reinstall a ubuntu 16.04 server from zero the server and get the same error.

    I tried the installer in a debian 9 and it work perfectly.

    The only difference is that in debian is not required install hhvm. In ubuntu 16.04 after install hhvm in the end of the install, appear this message but I didn't execute this commands. ¿Could be this?
    ********************************************************************
    * HHVM is installed.
    *
    * Running PHP web scripts with HHVM is done by having your
    * webserver talk to HHVM over FastCGI. Install nginx or Apache,
    * and then:
    * $ sudo /usr/share/hhvm/install_fastcgi.sh
    * $ sudo /etc/init.d/hhvm restart
    * (if using nginx) $ sudo /etc/init.d/nginx restart
    * (if using apache) $ sudo /etc/init.d/apache restart
    *
    * Detailed FastCGI directions are online at:
    * https://github.com/facebook/hhvm/wiki/FastCGI
    *
    * If you're using HHVM to run web scripts, you probably want it
    * to start at boot:
    * $ sudo update-rc.d hhvm defaults
    *
    * Running command-line scripts with HHVM requires no special setup:
    * $ hhvm whatever.php
    *
    * You can use HHVM for /usr/bin/php even if you have php-cli
    * installed:
    * $ sudo /usr/bin/update-alternatives \
    * --install /usr/bin/php php /usr/bin/hhvm 60
    ********************************************************************

    I execute the lines:

    $ sudo /usr/share/hhvm/install_fastcgi.sh
    $ sudo /etc/init.d/hhvm restart
    $ sudo update-rc.d hhvm defaults
    $ sudo /usr/bin/update-alternatives \
    --install /usr/bin/php php /usr/bin/hhvm 60

    But the errors continue:

    [Thu Sep 21 15:52:05.308452 2017] [fcgid:warn] [pid 30058] (104)Connection reset by peer: [client 192.168.1.26:45932] mod_fcgid: error reading data from FastCGI server
    [Thu Sep 21 15:52:05.308515 2017] [core:error] [pid 30058] [client 192.168.1.26:45932] End of script output before headers: index.php
    [Thu Sep 21 15:52:06.410496 2017] [fcgid:warn] [pid 30059] (104)Connection reset by peer: [client 10.0.1.26:45934] mod_fcgid: error reading data from FastCGI server
    [Thu Sep 21 15:52:06.410561 2017] [core:error] [pid 30059] [client 192.168.1.26:45934] End of script output before headers: index.php
    [Thu Sep 21 15:52:54.490306 2017] [fcgid:warn] [pid 30062] (104)Connection reset by peer: [client 192.168.1.26:46004] mod_fcgid: error reading data from FastCGI server
    [Thu Sep 21 15:52:54.490395 2017] [core:error] [pid 30062] [client 192.168.1.26:46004] End of script output before headers: index.php
     
    Last edited: Sep 22, 2017
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    HHVM is a optional PHP mode and not used by the ISPConfig interface itself, so that's most likely not related.

    You installed the server by using the perfect server tutorial for Ubuntu 16.04? https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/
     
  5. andresgt2000

    andresgt2000 Member

    Hi Till

    Yes I have used that manual, and in it not said that hhvm is an optional module, then I had thought that it is required.

    In this moment I am going to do my third install try becouse today I got an update about hhvm. If not work, I going to install the server without hhvm.

    I just finished I tell you whether it works or not.
     

    Attached Files:

  6. andresgt2000

    andresgt2000 Member

    Hi

    I install the server with hhvm and without hhvm and I got the same error when I try to access to the panel.

    "Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log."

    Apache2 -> error.log

    [Mon Sep 25 16:54:19.105377 2017] [fcgid:warn] [pid 29854] (104)Connection reset by peer: [client 192.168.1.26:53114] mod_fcgid: error reading data from FastCGI server
    [Mon Sep 25 16:54:19.105476 2017] [core:error] [pid 29854] [client 192.168.1.26:53114] End of script output before headers: index.p
     
    Last edited: Sep 26, 2017
  7. HSorgYves

    HSorgYves Active Member

    How did you try to access the server?
    What's the output of apachectl -S?
     
  8. andresgt2000

    andresgt2000 Member

    Hi HSorgYves

    I access to the server through https://galactica.test.net:8080

    This is the output of the command:

    ~$ sudo apachectl -S
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:72
    VirtualHost configuration:
    *:8081 galactica.test.net (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:80 galactica.test.net (/etc/apache2/sites-enabled/000-default.conf:1)
    *:8080 galactica.test.net (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex authdigest-client: using_defaults
    Mutex fcgid-proctbl: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/lock/apache2" mechanism=fcntl
    Mutex mpm-accept: using_defaults
    Mutex fcgid-pipe: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: ENABLE_USR_LIB_CGI_BIN
    User: name="www-data" id=33
    Group: name="www-data" id=33
     
  9. andresgt2000

    andresgt2000 Member

    This is the config files of the server but I don't see something wrong in them.
     

    Attached Files:

  10. andresgt2000

    andresgt2000 Member

    Hi

    I made the update to ISPConfig 3.1.7 but the issue in Ubuntu continue

    I am going to compare the config files from apache of Debian 9 and Ubuntu 16.04.
     
  11. andresgt2000

    andresgt2000 Member

    Hi

    The ISPConfig files of site-enables in apache are equals in Debian and Ubuntu Server.

    The only difference is how the PHP-FPM is installed, in Ubuntu install libapache2-mod-fastcgi and in in Debian not use it.

    Could be a misconfiguration of the fastcgi module?

    This is the content of the fastcgi.conf:

    "<IfModule mod_fastcgi.c>
    AddHandler fastcgi-script .fcgi
    #FastCgiWrapper /usr/lib/apache2/suexec
    FastCgiIpcDir /var/lib/apache2/fastcgi
    </IfModule>"


    This is the content of the fastcgi.load:

    "LoadModule fastcgi_module /usr/lib/apache2/modules/mod_fastcgi.so"
     

    Attached Files:

  12. HSorgYves

    HSorgYves Active Member

    $ ping galactica.test.net
    ping: cannot resolve galactica.test.net: Unknown host
     
  13. andresgt2000

    andresgt2000 Member

    Hi HSorgYves

    The server is in a Intranet and it can not reached from internet.

    I am practice to migrate my actual infrastructure and I want use Ubuntu Servers LTS.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok as Debian 9 does not has the mod_fastcgi package anymore.

    The Ubuntu setup uses mod_fcgi (for php-fcgi) and mod_fastcgi (for php-fpm). The ISPConfig vhost is using php-fcgi so mod_fastcgi is not involved at all.

    Are you sure that you did not left anything out from the tutorial. I haven't installed it for a few weeks, it always worked by simply copy/pasting the commands.
     
  15. andresgt2000

    andresgt2000 Member

    Hi Till, I hope you are very well.

    I am pretty sure I have followed the installation tutorial and have copied and pasted all the lines of the installation; The only thing I do not install or configure is the mailman since it is optional.

    But just in case, today I did a completely new installation in both Debian 9 and Ubuntu 16.04, even to be sure; I downloaded the iso of ubuntu server again.

    The result I got is that in debian 9 the panel works perfectly and I was able to enter it with no problems; instead in ubuntu 16.04 I get the same error as I posted before.

    At this moment the only thing that occurs to me; is to try installing with Ubuntu Server 17.04.
     

Share This Page