ERROR: Unable to load SQL-Dump into database table.

Discussion in 'Installation/Configuration' started by 14nw0lf, May 19, 2010.

  1. 14nw0lf

    14nw0lf New Member

    Trying to install ispconfig3 i get the following error

    ERROR: Unable to load SQL-Dump into database table.

    I have tried removing ispconfig3 completely from my system

    steps that i have done so far

    I ran rm -rf /tmp/trunk / redownloaded ispconfig3 / unable to uninstall before re-installing ispconfig3

    also ran updatedb / locate ispconfig3_install

    when running locate ispconfig3_install this is the output i get

    /home/toki/.local/share/Trash/info/ispconfig3_install.trashinfo - NO CLUE

    when running uninstall.php output was

    >> Uninstall

    PHP Warning: require(/usr/local/ispconfig/server/lib/config.inc.php): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/uninstall.php on line 50
    PHP Fatal error: require(): Failed opening required '/usr/local/ispconfig/server/lib/config.inc.php' (include_path='.:/usr/share/pear:/usr/share/php') in /tmp/ispconfig3_install/install/uninstall.php on line 50


    any advised?
     
    Last edited: May 19, 2010
  2. till

    till Super Moderator

    Looks as if you tried to install a SVN version instead of a stable version. SVN versions are only for developers and they are untested and might not work at all. Please use the currently released version 3.0.2.1.
     
  3. 14nw0lf

    14nw0lf New Member

    Thanks a million till :D that did it, re-downloaded the 3.0.2.1. just about now before heading to work and it work perfectly

    you were right i was using SVN version of ispconfig 3 :eek:

    thanks again buddy
     
  4. dharshini123

    dharshini123 New Member

    file system data structure difference between linux cp and mv command

    Hi,

    I am facing one problem only with mv command not with cp command. I have a test program

    #include <stdio.h>
    #include <string.h>
    #include <sys/types.h>
    #include <sys/stat.h>
    #include <sys/mount.h>
    #include <fcntl.h>
    #include <errno.h>

    int sync_file(char *file)
    {
    FILE *fp=NULL;
    int fd;

    printf("file is %s\n",file);
    fp = fopen(file, "r");
    if(!fp)
    return -1;

    fd = fileno(fp);
    fflush(fp);
    fsync(fd);
    ioctl (fd, BLKFLSBUF, 0);
    fclose(fp);
    return 0;

    }

    int main()
    {
    int len=0;
    FILE *fp = NULL;
    char buf[1024];
    char *fname = "/etc/test.conf";
    char fname_tmp[129] = "";


    len = sprintf(buf, "%s\n", "Newly added Line is there");

    snprintf(fname_tmp, 128, "%s.tmp", fname);

    if( (fp = fopen(fname_tmp,"a")) == NULL )
    printf(" ERROR: open(), error - %s\n",strerror(errno));

    fprintf(fp,"%s",buf);
    fflush(fp);

    fsync(fileno(fp));
    fclose(fp);
    system("cp -f /etc/test.conf.tmp /etc/test.conf");
    // system("mv -f /etc/test.conf.tmp /etc/test.conf");
    sync_file(fname);
    return 0;
    }

    Here i am opening a tmp file for writing. Then i am copying/moving for original file. Then i do a fflush, fsync(), ioctl() to the original file. Then i run this binary in linux machine(ext2 file system, 2.6.23.5 kernel) after that immediately power off the machine. Then power on machine, the file is disappeared or written data lost or file gets corrupted if i move the tmp file to the original file. And there is a no problem if i copy the tmp file to original file. So i want to know the difference between the cp and mv command. Can you please give me suggestion on it?

    Thanks,
    Indira.
     

Share This Page