ERROR: The PHP binary coming with ISPConfig does not work properly on your system!

Discussion in 'Installation/Configuration' started by yahooadam, Nov 10, 2007.

  1. yahooadam

    yahooadam New Member

    I'm using Fedora Core 5

    I was trying to update ISPConfig (a while ago) and this is the problem Ive been having, Ive spent many many hours

    Ive gone through and run yum update/install on every command in the HowTo

    Ive even uninstalled mysql and PHP, with no luck
    Code:
    yum remove php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc 
    Any help would be greatly apprieciated
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please make sure that the mysql-devel package is installed, and that SELinux is switched off.
     
  3. yahooadam

    yahooadam New Member

    Code:
    [root@hostname install_ispconfig]# yum install mysql-devel
    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    core                                                                 [1/3]
    updates                                                              [2/3]
    extras                                                               [3/3]
    Reading repository metadata in from local files
    Parsing package install arguments
    Nothing to do
    Code:
    [root@hostname install_ispconfig]# yum update mysql-devel
    Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    core                                                                 [1/3]
    updates                                                              [2/3]
    extras                                                               [3/3]
    Reading repository metadata in from local files
    Could not find update match for mysql-devel
    No Packages marked for Update/Obsoletion
    SELinux is also disabled

    Edit:
    Code:
    [root@yi install_ispconfig]# yum remove mysql-devel
    Loading "installonlyn" plugin
    Setting up Remove Process
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package mysql-devel.i386 0:5.0.27-1.fc5 set to be erased
    --> Running transaction check
    
    Dependencies Resolved
    
    =============================================================================
     Package                 Arch       Version          Repository        Size
    =============================================================================
    Removing:
     mysql-devel             i386       5.0.27-1.fc5     installed         5.5 M
    
    Transaction Summary
    =============================================================================
    Install      0 Package(s)
    Update       0 Package(s)
    Remove       1 Package(s)
    Is this ok [y/N]: n
    Exiting on user Command
    So its definetly installed
     
    Last edited: Nov 12, 2007
  4. yahooadam

    yahooadam New Member

    Bump .... :(
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Unfortunately I don't know a solution... :(
     
  6. yahooadam

    yahooadam New Member

    Anyone else have any suggestions

    Or perhaps any suggestions what to do now, i really need my webspace >_<

    Is it possible to upgrade to newer versions of fedora core without re-installing the OS (and using SSH)
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you install all pacakges exactly as described in the perfect setup guide?
     
  8. yahooadam

    yahooadam New Member

    Yeah i did

    This used to work, this install is probably like 3 years old now, i just wanted to upgrade ispconfig

    ive also tried
    Code:
    yum update fetchmail wget bzip2 unzip zip nmap openssl lynx fileutils ncftp quota bind-chroot mysql mysql-devel mysql-server cyrus-sasl cyrus-sasl-devel cyrus-sasl-gssapi cyrus-sasl-md5 cyrus-sasl-plain postfix dovecot php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel proftpd webalizer ntp perl-HTML-Parser perl-DBI perl-Net-DNS perl-Digest-SHA1 screen pinfo
    which updates every package in the article, with no luck (and i tried with install first to make sure their all installed)
     
  9. RM07

    RM07 New Member

    Hi there, I'm also getting this error and its becoming very tedious!

    I've yum installed alot of stuff, and I've also tried reinstalling. The server is currently CentOS 4.4 (64 Bit) I've read through the forums and googled long and hard but I can't find a soloution!

    Any help is greatly appritated!!
    -R
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    @RM07

    Your error is not related to the problem in this thread. You missed step 15 in the installation documenation for ISPConfig on Centos 4.4:

    http://www.howtoforge.com/perfect_setup_centos_4.4_p6

    Please install the HTML::parser perl module as described there and unpack the ISPConfig installer tar.gz file again and run the setup script.
     

Share This Page