Error starting Lighttpd

Discussion in 'Server Operation' started by jadude, Nov 22, 2009.

  1. jadude

    jadude New Member

    Hello there i am running a webserver on ubuntu 8.04

    My problem is since recently without changing anything to the server it keeps dropping permission for lighttpd log directory

    so i have to run a command each time to chown the directory before i can get lighttpd running

    Error Below

    opening errorlog '/var/log/lighttpd/error.log' failed: Permission denied
    Opening errorlog failed. Going down.

    I have to run chown -R www-data:www-data /var/log/lighttpd before restarting the server, does anyone knows how to fix this please.

    Thank you. I used the tutorials found on this site to Install my webserver
    You guys ROCK

    Thanks in advance
  2. falko

    falko Super Moderator ISPConfig Developer

    Who owns the directory before you run the chown command?
  3. jadude

    jadude New Member

    www-data owns the directory which is the user for lighttpd
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    ls -la /var/log/lighttpd/
    when the ownerships are wrong?
  5. jadude

    jadude New Member

    This is the output of the directory
  6. damir

    damir New Member


    chown www-data:www-data /var/log/lighttpd/error.log

    and restart you lighttpd service.
  7. jadude

    jadude New Member

    ok thanks, hopefully it shouldnt lose permissions now
  8. jadude

    jadude New Member

    After a Few hours its back. syslog has taken permission of error.log once more

  9. falko

    falko Super Moderator ISPConfig Developer

    I think you should check your syslogd configuration.
  10. jadude

    jadude New Member

    These are the only reference i see of lighttpd in syslog.conf

    i commented them out and will be testing to see if this works

Share This Page