ERROR: server reached MaxRequestWorkers

Discussion in 'General' started by SuperLOL, Oct 21, 2020.

  1. SuperLOL

    SuperLOL Member

    HI,
    How can i fix this error i cannot find any mpm_prefork.conf file in the ISPConfig folders. :eek:

     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    It would be somewhere under /etc/apache2/ (in mods-available maybe?) in debian, and I think it's /etc/httpd/ on centos. Or simply `find /etc/ -name mpm_prefork.conf`.
     
    SuperLOL likes this.
  3. SuperLOL

    SuperLOL Member

    Thanks, I found it now. I must have overlooked this folder "/etc/apache2/mods-available". :rolleyes:
    One little question, is the ISPConfig setting "PHP-FPM pm.max_children" the same setting as the "MaxRequestWorkers"? If not can we set the "MaxRequestWorkers" directly in ISPConfig? :)
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No, the former is a setting of a php-fpm daemon, the latter of the mpm_prefork apache module.
    I doubt it, but just edit the .conf file directly. (Side note: you probably don't even want to run mpm_prefork nowadays, as it precludes http/2.)
     
    SuperLOL likes this.
  5. SuperLOL

    SuperLOL Member

  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Find that setting in the .conf file, or add it if needed, increase it to what you need, and restart apache.
     
    SuperLOL likes this.

Share This Page