Error sending emails from web app

Discussion in 'General' started by hadizeid, Jan 14, 2021.

  1. hadizeid

    hadizeid Member

    Hello Everyone,
    facing once issue here with a client unable able to send email from his web application. that issue was not there before upgrading 3.2.2, there no complain when upgraded to 3.2 or atleast no complain. I am on Debian 10 with nginx single server. the error in mail log is "
    Code:
    Jan 14 09:08:23 mhd001 postfix/submission/smtpd[18991]: warning: hostname server14767.domain.com does not resolve to address XX.XX.XX.XX: Name or service not known
    Jan 14 09:08:23 mhd001 postfix/submission/smtpd[18991]: connect from unknown[XX.XX.XX.XX]
    Jan 14 09:08:25 mhd001 postfix/proxymap[18936]: warning: table "mysql:/etc/postfix/mysql-virtual_sender_login_maps.cf": empty lookup result for: "[email protected]" -- ignored
    Jan 14 09:08:25 mhd001 postfix/submission/smtpd[18991]: NOQUEUE: filter: RCPT from unknown[XX.XX.XX.XX]: <[email protected]>: Sender address triggers FILTER lmtp:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<server77535>
    Jan 14 09:08:25 mhd001 postfix/proxymap[18936]: warning: table "mysql:/etc/postfix/mysql-virtual_sender_login_maps.cf": empty lookup result for: "[email protected]" -- ignored
    Jan 14 09:08:25 mhd001 postfix/submission/smtpd[18991]: NOQUEUE: reject: RCPT from unknown[XX.XX.XX.XX]: 550 5.1.0 <[email protected]>: Sender address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<server77535>
    Jan 14 09:08:25 mhd001 postfix/submission/smtpd[18991]: lost connection after RCPT from unknown[XX.XX.XX.XX]
    Jan 14 09:08:25 mhd001 postfix/submission/smtpd[18991]: disconnect from unknown[XX.XX.XX.XX] ehlo=2 starttls=1 auth=1 mail=1 rcpt=0/1 commands=5/6
    appreciate your support. as i was trying to search for "Sender address rejected: User unknown in virtual mailbox table" but wasn't able to figure out how to fix

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Add a # in front of the line:

    smtpd_reject_unlisted_sender = yes

    in /etc/postfix/main.cf and restart postfix.
     
  3. hadizeid

    hadizeid Member

    Hi Till i did this an did't help.
    however this specific mailbox have enable receiving unchecked. tried check marking it and emails and emails went through to the gmail client. not sure if that could be an issue however still trying to read an investigate.
    and suggestions are appreciated
     

    Attached Files:

  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    If you disable receiving, you disable postfix for that user iirc. This is confusing and I discussed this with @Jesse Norell recently but can't find where and what was the outcome of that :confused:
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Disable delivery if you only want to send from that account. That is confusing that "enable receiving" affects sending; the setting is for everything to do with postfix, I don't know if it's be better to change the label or rework queries so that it only affects receiving. The receiving vs delivery can also be confusing.
     
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Maybe a rework would be better?
     

Share This Page