Error - Relay access denied

Discussion in 'General' started by bogdan747, Mar 13, 2008.

  1. bogdan747

    bogdan747 New Member

    Hi Guys

    I have just setup ISP config,
    I can send the email but can get the reply from anyone, and i am sure you will not be able to send me anything either.

    below is the error message

    This is an automatically generated Delivery Status Notification

    Delivery to the following recipient failed permanently:

    [email protected]

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 13): 554 5.7.1 <[email protected]>: Relay access denied

    ----- Original message -----

    Received: by with SMTP id v15mr5851292rve.168.1205423270054;
    Thu, 13 Mar 2008 08:47:50 -0700 (PDT)
    Received: by with HTTP; Thu, 13 Mar 2008 08:47:50 -0700 (PDT)
    Message-ID: <[email protected]>
    Date: Fri, 14 Mar 2008 02:47:50 +1100
    From: "Bogdan Bednarczyk" <[email protected]>
    To: "Bogdan B." <[email protected]>
    Subject: Re: test2
    In-Reply-To: <[email protected]>
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    References: <[email protected]>

    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: 7bit
    Content-Disposition: inline
  2. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

  3. bogdan747

    bogdan747 New Member

    No Go,

    Thanks grandpagenocide

    unforunately the first post has different symptoms

    the second has not fixed my problem

    I decided to check another domain i have namely ´´ so i woiuld like to send the email to [email protected] but also when i go to it goes to SharedIP website. (?) I am sure that this is just a hick up at the beginning of my trek with ISPconfig, but i wonder if other people have same problems or it is my stupidity that does not let me go through. :confused:

    just on the surface it looks that my server does not handshake properly,
    what did I do wrong?

    Thanks in advance

    here is a reply from my server:
    from Mail Delivery System <[email protected]>
    to [email protected],
    date Fri, Mar 14, 2008 at 5:58 PM
    subject Undelivered Mail Returned to Sender

    hide details 5:58 PM (5 minutes ago)


    This is the mail system at host

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <[email protected]> (expanded from <[email protected]>): mail
    for loops back to myself

    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.4.6
    Diagnostic-Code: X-Postfix; mail for loops back to myself

    ---------- Forwarded message ----------
    From: "Bogdan Bednarczyk" <[email protected]>
    To: [email protected]
    Date: Fri, 14 Mar 2008 17:58:27 +1100
    Subject: test sending to atcentre mail
    test from

    here is a dig for
    [email protected]:/var/www/web3# dig MX

    ; <<>> DiG 9.4.1-P1 <<>> MX
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9350
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 2

    ; IN MX

    ;; ANSWER SECTION: 21600 IN MX 20

    ;; AUTHORITY SECTION: 19331 IN NS 19331 IN NS 19331 IN NS

    ;; ADDITIONAL SECTION: 21600 IN A 4139 IN A

    ;; Query time: 348 msec
    ;; SERVER:
    ;; WHEN: Fri Mar 14 17:43:30 2008
    ;; MSG SIZE rcvd: 143

    and the /var/mail.log

    Mar 14 17:58:29 isp1 postfix/smtpd[23191]: connect from[]
    Mar 14 17:58:29 isp1 postfix/smtpd[23191]: DD66B36C0C6:[]
    Mar 14 17:58:30 isp1 postfix/cleanup[23199]: DD66B36C0C6: message-id=<[email protected]>
    Mar 14 17:58:30 isp1 postfix/qmgr[4626]: DD66B36C0C6: from=<[email protected]>, size=2472, nrcpt=1 (queue active)
    Mar 14 17:58:30 isp1 postfix/smtpd[23204]: connect from unknown[]
    Mar 14 17:58:30 isp1 postfix/smtp[23202]: warning: host[]:25 greeted me with my own hostname
    Mar 14 17:58:30 isp1 postfix/smtp[23202]: warning: host[]:25 replied to HELO/EHLO with my own hostname
    Mar 14 17:58:30 isp1 postfix/smtp[23202]: DD66B36C0C6: to=<[email protected]>, orig_to=<[email protected]>,[]:25, delay=1.3, delays=0.7/0.01/0.6/0, dsn=5.4.6, status=bounced (mail for loops back to myself)
    Mar 14 17:58:31 isp1 postfix/smtpd[23204]: disconnect from unknown[]
    Mar 14 17:58:31 isp1 postfix/cleanup[23199]: 0167236C605: message-id=<[email protected]>
    Mar 14 17:58:31 isp1 postfix/qmgr[4626]: 0167236C605: from=<>, size=4316, nrcpt=1 (queue active)
    Mar 14 17:58:31 isp1 postfix/bounce[23207]: DD66B36C0C6: sender non-delivery notification: 0167236C605
    Mar 14 17:58:31 isp1 postfix/qmgr[4626]: DD66B36C0C6: removed
    Mar 14 17:58:34 isp1 postfix/smtp[23202]: 0167236C605: to=<[email protected]>,[]:25, delay=4, delays=0.02/0/1.9/2.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1205477914 v35si5193347wah.19)
    Mar 14 17:58:35 isp1 postfix/qmgr[4626]: 0167236C605: removed
    Mar 14 17:59:00 isp1 postfix/smtpd[23191]: disconnect from[]
    Mar 14 18:00:01 isp1 postfix/smtpd[23204]: connect from localhost[]
    Mar 14 18:00:01 isp1 postfix/smtpd[23204]: lost connection after CONNECT from localhost[]
    Mar 14 18:00:01 isp1 postfix/smtpd[23204]: disconnect from localhost[]
    Mar 14 18:00:01 isp1 courierpop3login: Connection, ip=[::ffff:]
    Mar 14 18:00:01 isp1 courierpop3login: Disconnected, ip=[::ffff:]
  4. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    This is going to sound kind of dumb, but I had the same issue of the shared ip coming up instead of the actual domain, try deleteing the user and emptying the recycle bin, then restart ispconfig_server and recreate the user. It fixed that for me.
  5. bogdan747

    bogdan747 New Member

    Thanks grandpagenocide

    That did work, with the SharedIP and mail (read on about mail though)

    In original setup I had one client with 2 web sites and not much setting so i removed the sites and the client, empty the Recycle Bin, then restarted ISPconfig

    Then added the client again, addded the sites (here I have to add I set internal IP ´´ for the site server not external 58.108.... then added mail users, and it worked.

    gmail send the email no problem and my domain accept it.
    and both sites shows in their respective web-spaces

    In retrospect i think that it was my fault because I set External IP (58.108...) to the ´Server 1´ caused ´Relaying Denied´. It was when sever parsing the requests going out to the external IP again rather than to local.

    Thanks for reply guys
  6. bogdan747

    bogdan747 New Member

    Hello again

    I have added two more domains and they are showing in the SharedIP part,

    I have checked the directory under /var/www/ and there are no ./web8 or ./web9/ which would be the next consecutive web. Moreover when I logged in with the user_ID there was no new webs added to the management.
    So I restarted /etc/inet.d/ispconfig_server restart
    Still nothing, so i restarted the whole computer,
    the webs show in the user_management but the directories under /var/www/ still not created, hence webs are showing to the SharedIP. The only change I made since the first problem ... I have added the mods for [email protected] email access (which works OK)

    I know that grandpagenocide said to delete the user and empty recycle_bin but if i have to delete the user every time i want to add the website that would be a bit much.

    Can anyone tell me why the new webs not creating directories, and or symlinks to the web_name?

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe there is a syntax error in one of the ispconfig libraries now. Please run the following command on the shell as root:

    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    Do you get any errors?
  8. bogdan747

    bogdan747 New Member

    Thanks, SharedIP solved

    Thanks Till and grandpagenocide
    yes, there was

    Parse error: syntax error, unexpected '.' in /root/ispconfig/scripts/writeconf.php on line 306
    I made a ¨Boo-Boo¨ in the path to the new script, And it worked the first time because I run it outside of the writeconf.php

    thanks again, :)
    As always, it shows that being involved in the creation of the software makes the difference in alertness.


Share This Page