(error postgresql-devel)Virtual Users With Postfix, PostfixAdmin...CentOS

Discussion in 'HOWTO-Related Questions' started by bacanchileno, Feb 6, 2007.

  1. bacanchileno

    bacanchileno New Member

    Hello to all
    In this manual, when i execute the step : sudo yum install libtool postgresql-devel ... , appear the next error = (Error: Missing Dependency: postgresq = 7.4.l3-2...., etc), and not continue.

    I need help, please

  2. xraymind

    xraymind New Member

    I got around this problem. But here is a warning, you will not likely to get this mail server working. As I am stuck on page 5/6 right now. This howto is too new, it still have some mistakes that needs to be fixed.

    If you want to continue. The postresql-server was installed with centosplus, which installed version 8.xxxx. Now the regular yum install for postresql-devel is going try install version 7.xxxx, so the two versions don't match up. postresql is not really use by this howto, but needed by courier to make the rpm packages. Anyway just do "yum install --enablerepo=centosplus postgresql-devel" and remove postresql-devel from the sudo yum install.

    Later on, it tells you to vi maildirmake.sh twice, which the second one should be vi maildirdel.sh. The problem is these shell scripts don't work when postfixadmin calls to them. I even chmod +x on scripts. The problem I think the instructions on modifying the php scripts are not very clear. I was unsure where to place the changes. So directory for the domain and user are never created by postfixadmin. When I manually created them use the instructions, maildrop/courier aren't finding them.

    Well for me, I wasted a whole day to get this point. I will have to look at another howto guide. As this one has not been fully tested.
    Last edited: Feb 7, 2007
  3. cryptic

    cryptic Member

    Ack! Thanks for the lookout. Hopefully the author edits his posting, as I regard the HowTo's as step by step, this will work sort of deal :)
  4. d34m0n1x

    d34m0n1x New Member

    I have the same problem.
    Error: compat-postgresql-libs conflicts with postgresql-libs < 8.0.2
    "yum install --enablerepo=centosplus postgresql-devel" doesn't work for me.

    I don't have installed postresql-devel.
  5. falko

    falko Super Moderator ISPConfig Developer

    Do you have a file for the centosplus repository in /etc/yum.repos (or was it /etc/yum.repos.d)?
  6. unclecameron

    unclecameron New Member

    I also had problems with:
    yum install mysql-devel pam-devel gcc-c++ postgresql-devel
    Error: Missing Dependency: postgresql = 7.4.16-1.RHEL4.1 is needed by package postgresql-devel
    Error: Missing Dependency: postgresql-libs = 7.4.16-1.RHEL4.1 is needed by package postgresql-devel

    so then I went and found those packages on rpmfind.net and tried to install them, but they had a bunch of dependency errors. so then I figured postgres probably wasn't used anyway, but that ran into problems doing the rpmbuild for courier-authlib-0.58.tar.bz2

    Also I got a warning about directly editing /etc/sudoers, so I added vmail user using /usr/sbin/visudo

    I notice the author said he had a really hard time getting CentOS to behave for the install, CentOS just doesn't seem to be keeping up like some other distros.
    If I wasn't shooting for the RHCE program, I'd ditch RH altogether and run Debian/Ubuntu, Centos is great, but needs some updating to catch up, has anyone tried this on Centos 5, that is looking pretty sweet from what I've tested?

    San Diego
  7. cryptic

    cryptic Member

    Any update on this? If not, then this How To should be removed.
  8. cryptic

    cryptic Member

    This is what worked for me:

    First I noticed that the postgresql-libs i had installed was 8.1.8-1.el4s1.1, which is what is in CentOS Plus. Not sure why this version was installed. I remove this package and it removed the other postgresql packages.

    I also made sure that my ceotusplus entry in yum.repos.d/CentOS-Base.repo looked this this:

    name=CentOS-$releasever - Plus

    The 'yum install libtool postgresql-devel gdbm-devel pam-devel expect openldap-devel' installed just fine.

Share This Page