Error on re-install

Discussion in 'Installation/Configuration' started by omni, Jan 11, 2007.

  1. omni

    omni New Member

    So I've following this guide to setup my new server. I had some bumps along the way but I believe that I got everything completed in the guide. Well after the install of ISPConfig I was able to pull up the config login (https://192.162.100:81) however I was unable to login using the default login (u:admin p:admin). During my install of ISPConfig I ended up having to reset my mysql password which took me a little while but I got it all done and the install appeared to complete just fine. however, like I said I was unable to log in. I figured it had something to do with my little mysql bump. So... I decided to just try and re-install ISPConfig... everything appeared to go fine up until the end when I receive this:

    Code:
    All prerequisites are fulfilled.
    Here we go...
    
    Connected successfully to db db_ispconfig
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 692
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 717
    mysqldump: Got error: 1045: Access denied for user 'root'@'localhost' (using password: YES) when trying to connect
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 806
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 811
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 821
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 838
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/aberrix/install_ispconfig/install.php on line 1144
    Restarting some services...
    ./setup2: line 1115: [: ==: unary operator expected
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Syntax error on line 1072 of /root/ispconfig/httpd/conf/httpd.conf:
    ServerName takes one argument, The hostname of the server
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    but when I go to the ISPConfig login (https://192.168.0.100:81) the page no longer comes up. I fear I've done something to completely bork the system... Can someone please provide me some insight as to what I've done wrong and what I can do to correct this? Thanks in advance.
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    1st try to remove everything related to ispconfig. There is an un-install script IIRC in the extracted setup directory.
    Otherwise, rm /root/ispconfig /home/admispconfig and delete the database from MySQL. Guess you have to do that with a mysqladmin. Then reinstall ispc.

    I think this is the easiest way to recover. Of course you can try to find what's wrong, but that may take a while to figure out.
     
  3. omni

    omni New Member

    thanks for the prompt response! and excuse my noob-ness... I see an uninstall script in there.

    I am running Ubuntu 6.10

    when I try sudo ./uninstall I get errors
    also when I su - and then try ./uninstall

    how do I execute it properly?

    thanks in advance
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    As your installation is incomplete, the uninstall script wont work properly. Please uninstall ISPConfig by executing:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    and make sure that you delete the ISPConfig mysql database too. There should be no database with the name that you enter in the ISPConfig installer.
     
  5. omni

    omni New Member

    I tried the '/root/ispconfig/uninstall' command and as you said till, it doesnt want to work because the installation is not complete. I've removed both of those directories and I believe I have dropped the database 'mysqladmin drop db_ispconfig' so I am now going to try and re-install...

    thanks again!
     
  6. omni

    omni New Member

    Alright, my re-install is complete and 'appears' to have gone okay but with a couple bumps.

    1) I can bring up the ISPConfig login page (https://192.168.0.100:81), however I STILL CANNOT LOGIN

    I received the following at the end of the installation.

    Code:
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
    1) HTTPS
    2) HTTP
    Your Choice: 1
    
    Connected successfully to MySQL server
    [b]ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)[/b]
    Restarting some services...
     * Stopping Postfix Mail Transport Agent postfix                                                                  [ ok ]
     * Starting Postfix Mail Transport Agent postfix                                                                  [ ok ]
    Restarting ProFTPD ftp daemon.proftpd
    ..proftpd
     done
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    
    [b]Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47[/b]
    No results found!FreshClam is already running!
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to
    
    https://www.XXXXX.XXX:81
    
    and log in:
    Username: admin
    Password: admin
    what do those errors mean? are they the reason I cannot login? Thanks in advance.
     
  7. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    It means something went wrong with your database setup. Either you have not deleted it, or you specified the wrong password for root during the procedure. Hate to say this, but I don't see another option as another re-install:(
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Which mysql user dis you enter in the installer? It should be root or a mysql user with the same priveliges like the mysql root user.
     
  9. omni

    omni New Member

    alright, after some troubleshooting I've discovered that I manually tried to enter my root sql password into '/etc/mysql/my.cnf'. Which should have been okay except that the password contained a '$' and it did not like that, I changed it to something else and it appears I can connect to the mysql server just fine now... so I've re-deleted the ispconfig directories, removed the table and giving the install another shot again...
     
  10. omni

    omni New Member

    holy crap! it works!!!!

    I just successfully logged in and changed the admin password.

    thank you for all of your time and your help!
     
  11. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    $, >, <, !, &, *, (, ) are to be used with care in passwords. Most of the times it works, but sometimes they bite you.
     

Share This Page