Error message: Invalid command 'SuexecUserGroup'..??

Discussion in 'Installation/Configuration' started by oakleaf, Jan 17, 2012.

  1. oakleaf

    oakleaf New Member

    Hey.

    I'm having a bit of a problem on an Ubuntu install of ISPCONFIG multi-server.

    Error message: Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration

    I've followed the guide, a2enmod suexec (etc) and so it is enabled but it looks as if Apache2 doesn't recognize the module as part of apache2?

    How can I fix this problem, and how do we proceed?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/apache2/mods-enabled/
    ?
     
  3. abdi

    abdi New Member

    Am getting exactly the same problem and below is my output


    root@ug201:/etc/apache2# ls -la /etc/apache2/mods-enabled/
    total 8
    drwxr-xr-x 2 root root 4096 Oct 6 11:27 .
    drwxr-xr-x 7 root root 4096 Oct 1 13:26 ..
    lrwxrwxrwx 1 root root 28 Oct 1 13:26 alias.conf -> ../mods-available/alias.conf
    lrwxrwxrwx 1 root root 28 Oct 1 13:26 alias.load -> ../mods-available/alias.load
    lrwxrwxrwx 1 root root 33 Oct 1 13:26 auth_basic.load -> ../mods-available/auth_basic.load
    lrwxrwxrwx 1 root root 33 Oct 1 13:26 authn_file.load -> ../mods-available/authn_file.load
    lrwxrwxrwx 1 root root 36 Oct 1 13:26 authz_default.load -> ../mods-available/authz_default.load
    lrwxrwxrwx 1 root root 38 Oct 1 13:26 authz_groupfile.load -> ../mods-available/authz_groupfile.load
    lrwxrwxrwx 1 root root 33 Oct 1 13:26 authz_host.load -> ../mods-available/authz_host.load
    lrwxrwxrwx 1 root root 33 Oct 1 13:26 authz_user.load -> ../mods-available/authz_user.load
    lrwxrwxrwx 1 root root 32 Oct 1 13:26 autoindex.conf -> ../mods-available/autoindex.conf
    lrwxrwxrwx 1 root root 32 Oct 1 13:26 autoindex.load -> ../mods-available/autoindex.load
    lrwxrwxrwx 1 root root 26 Oct 1 13:26 cgi.load -> ../mods-available/cgi.load
    lrwxrwxrwx 1 root root 30 Oct 1 13:26 deflate.conf -> ../mods-available/deflate.conf
    lrwxrwxrwx 1 root root 30 Oct 1 13:26 deflate.load -> ../mods-available/deflate.load
    lrwxrwxrwx 1 root root 26 Oct 1 13:26 dir.conf -> ../mods-available/dir.conf
    lrwxrwxrwx 1 root root 26 Oct 1 13:26 dir.load -> ../mods-available/dir.load
    lrwxrwxrwx 1 root root 26 Oct 1 13:26 env.load -> ../mods-available/env.load
    lrwxrwxrwx 1 root root 28 Oct 6 11:27 fcgid.conf -> ../mods-available/fcgid.conf
    lrwxrwxrwx 1 root root 28 Oct 6 11:27 fcgid.load -> ../mods-available/fcgid.load
    lrwxrwxrwx 1 root root 27 Oct 1 13:26 mime.conf -> ../mods-available/mime.conf
    lrwxrwxrwx 1 root root 27 Oct 1 13:26 mime.load -> ../mods-available/mime.load
    lrwxrwxrwx 1 root root 34 Oct 1 13:26 negotiation.conf -> ../mods-available/negotiation.conf
    lrwxrwxrwx 1 root root 34 Oct 1 13:26 negotiation.load -> ../mods-available/negotiation.load
    lrwxrwxrwx 1 root root 27 Oct 1 13:26 perl.load -> ../mods-available/perl.load
    lrwxrwxrwx 1 root root 27 Oct 1 13:26 php5.conf -> ../mods-available/php5.conf
    lrwxrwxrwx 1 root root 27 Oct 1 13:26 php5.load -> ../mods-available/php5.load
    lrwxrwxrwx 1 root root 29 Oct 1 13:26 python.load -> ../mods-available/python.load
    lrwxrwxrwx 1 root root 33 Oct 1 13:26 reqtimeout.conf -> ../mods-available/reqtimeout.conf
    lrwxrwxrwx 1 root root 33 Oct 1 13:26 reqtimeout.load -> ../mods-available/reqtimeout.load
    lrwxrwxrwx 1 root root 31 Oct 1 13:26 setenvif.conf -> ../mods-available/setenvif.conf
    lrwxrwxrwx 1 root root 31 Oct 1 13:26 setenvif.load -> ../mods-available/setenvif.load
    lrwxrwxrwx 1 root root 29 Oct 1 13:26 status.conf -> ../mods-available/status.conf
    lrwxrwxrwx 1 root root 29 Oct 1 13:26 status.load -> ../mods-available/status.load
     
  4. abdi

    abdi New Member

    I did try to resolve it by running:

    a2enmod suexec

    Now when I start apache I get the following error:


    root@ug201:/etc/apache2# /etc/init.d/apache2 start
    Starting web server: apache2Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
     
  5. abdi

    abdi New Member

    Resolved ...

    I didnt realize Nginx was also installed while setting up ISPConfig, so when I restarted the server, Nginx started before Apache and took up the port ..I stopped it and all works fine. Though however, I still get the warning errors

    root@ug201:# /etc/init.d/apache2 start
    Starting web server: apache2Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    .
    root@ug201:/etc/apache2#
     

Share This Page