Error installing Spamassassin

Discussion in 'Installation/Configuration' started by rdhir, Mar 22, 2010.

  1. rdhir

    rdhir New Member

    Hi,

    I am building a test server on a local VMware box (ESXi 4.0). My previous build a year ago for ISPConfig 3.0 went fine, but I am currently stuck here.

    Under VMWare ESXi 4.0u1 I have installed Centos 5.4
    I followed the How To, and all worked fine until installing spamassassin. This fails with

    I have installed per-Razor-Agent, razor-agents from dag wieers both by a download and rpm and by yum install, but the error will not go away. I have googled but not found any help other than install the above packages from dag wieers.

    Any help appreciated as I am now stuck

    cheers

    Rajiv
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which howto did you follow?
     
  3. rdhir

    rdhir New Member

  4. rygotype

    rygotype New Member

    Same problem.

    Code:
    [[email protected] ~]# yum install spamassassin
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * addons: mirrors.rit.edu
     * base: mirrors.xmission.com
     * extras: centos.corenetworks.net
     * rpmforge: ftp-stud.fht-esslingen.de
     * updates: yum.singlehop.com
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package spamassassin.i386 0:3.3.1-1.el5.rf set to be updated
    --> Processing Dependency: perl(Razor2) >= 2.61 for package: spamassassin
    --> Processing Dependency: perl(NetAddr::IP) >= 4.000 for package: spamassassin
    --> Processing Dependency: re2c for package: spamassassin
    --> Processing Dependency: perl(Mail::SPF) for package: spamassassin
    --> Processing Dependency: perl(Net::Ident) for package: spamassassin
    --> Processing Dependency: perl(IP::Country) for package: spamassassin
    --> Processing Dependency: perl(Encode::Detect) for package: spamassassin
    --> Running transaction check
    ---> Package perl-Encode-Detect.i386 0:1.01-1.el5.rf set to be updated
    ---> Package perl-IP-Country.noarch 0:2.27-1.el5.rf set to be updated
    --> Processing Dependency: perl(Geography::Countries) for package: perl-IP-Country
    ---> Package perl-Mail-SPF.noarch 0:2.006-1.el5.rf set to be updated
    --> Processing Dependency: perl(version) for package: perl-Mail-SPF
    --> Processing Dependency: perl(Error) for package: perl-Mail-SPF
    ---> Package perl-Net-Ident.noarch 0:1.20-1.2.el5.rf set to be updated
    ---> Package perl-NetAddr-IP.i386 0:4.027-1.el5.rf set to be updated
    ---> Package re2c.i386 0:0.13.5-1.el5.rf set to be updated
    ---> Package spamassassin.i386 0:3.3.1-1.el5.rf set to be updated
    --> Processing Dependency: perl(Razor2) >= 2.61 for package: spamassassin
    --> Running transaction check
    ---> Package perl-Error.noarch 0:0.17016-1.el5.rf set to be updated
    ---> Package perl-Geography-Countries.noarch 0:2009041301-1.el5.rf set to be updated
    ---> Package perl-version.i386 0:0.76-1.el5.rf set to be updated
    ---> Package spamassassin.i386 0:3.3.1-1.el5.rf set to be updated
    --> Processing Dependency: perl(Razor2) >= 2.61 for package: spamassassin
    --> Finished Dependency Resolution
    spamassassin-3.3.1-1.el5.rf.i386 from rpmforge has depsolving problems
      --> Missing Dependency: perl(Razor2) >= 2.61 is needed by package spamassassin-3.3.1-1.el5.rf.i386 (rpmforge)
    Error: Missing Dependency: perl(Razor2) >= 2.61 is needed by package spamassassin-3.3.1-1.el5.rf.i386 (rpmforge)
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    
    Using CentOS 5.4 as well.
     
  5. supanatral

    supanatral Member

    I'm getting the exact same problem.

    I know that for me, I originally downloaded SA from their homepage and built it from source. How about the rest of you?

    I don't know if that's the problem for me but I'm going to take a snapshot of the server after hours and try to uninstall it then install it from yum.
     
  6. rdhir

    rdhir New Member

    no I'm just doing a bogstandard yum of the rpm built by dag wieers or wherever rather than source.

    What's even more annoying about this is that AFAIK the razor package is optional, ie you can choose not to use it.

    I didn't even build the server again to test this, I want to dumnp email off to rackspace and just do other things like wordpress mu, sigh....

    Cheers


    Rajiv
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I did this centos install about 2 weeks ago and it worked at that time. But it might be that some dependencys in centos or rpmforge repos are broken at the moment.

    As a general note, I recommend to consider to use debian instead of centos. it is much easier to setup and will result in a more stable setup. You will get have less problems when installing and upgrading compared to centos as debian has all nescessary packages in its main repository and you dont have to compile software like courier.
     
  8. rdhir

    rdhir New Member

    Except that doesn't really work for my hosting provider as I'm trying to build a test environment close to my hosting provider..anyway that's my problem.

    Does anyone know of a way to get yum to ignore the dependency and tray and install anyway. I don't care if it crashes and burns as I can always build a new VM

    Cheers

    Rajiv
     
  9. supanatral

    supanatral Member

    This update was released on Friday at around noon last week so they probably don't have everything setup just yet. I think your right.

    I agree with Debian now...I've had quite a few dependency issues and software being outdated that I would like to switch to Debian but I just setup this server and I have it all customized to my liking for the most part. It's too bad!
     
  10. supanatral

    supanatral Member

    IMO - Your best bet, if you need to upgrade at this second, then go to:
    http://spamassassin.apache.org/downloads.cgi?update=200806121419

    download SA 3.3.1 and build the rpm from source. I think that will work but I can't promise you anything at this point because I haven't done it. I'll probably wait a few days to see if rpmforge gets things worked out and if not then I'll try it myself. Post back with your findings.
     
  11. rdhir

    rdhir New Member

    not afraid of compiling, but I don't really have time, need to do the wordpress install and will wait a few days for rpmforge to see if it catches up
     
  12. TAHAA

    TAHAA New Member

    Using CentOS version 5.4
    I solved spamassassin problem by first installing old version ie
    install
    Code:
    http://dag.wieers.com/rpm/packages/spamassassin/spamassassin-3.2.4-1.el5.rf.i386.rpm
    then update it with latest version
    Code:
    http://wtogami.fedorapeople.org/temp/spamassassin/el5/spamassassin-3.3.1-2.el5.i386.rpm
    rpm -Uvh spamassassin-3.3.1-2.el5.i386.rpm

    ####### if there is any perl Dependency is required , manually install from yum install perl-IO-Socket etc.#########


    Thanks
     
    Last edited: Mar 23, 2010
  13. supanatral

    supanatral Member

    Just a note to everyone that RPMforge issues has been resolved and SA can be updated/installed now.
     
  14. rygotype

    rygotype New Member

    i was just waiting it out.

    thank you for the update. much appreciated.
     
  15. TAHAA

    TAHAA New Member

    yes now there is no problem to install spamassassin
     

Share This Page